summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKostis Anagnostopoulos <ankostis@gmail.com>2016-09-25 18:55:15 +0200
committerKostis Anagnostopoulos <ankostis@gmail.com>2016-09-26 13:37:54 +0200
commit082851e0afd3a58790fe3c2434f6d070f97c69c1 (patch)
treeadb9138d09b2ca770ff85c69da316e1af9ede8c2
parent51bf7cbe8216d9a1da723c59b6feece0b1a34589 (diff)
downloadgitpython-082851e0afd3a58790fe3c2434f6d070f97c69c1.tar.gz
apveyor: simplify test.
-rw-r--r--.appveyor.yml22
-rw-r--r--git/test/test_util.py2
2 files changed, 9 insertions, 15 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 2af0ccdb..233ea4e3 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -2,15 +2,15 @@
environment:
matrix:
- - PYTHON: "C:\\Miniconda"
+ - PYTHON: "C:\\Python27"
PYTHON_VERSION: "2.7"
- PYTHON: "C:\\Miniconda"
PYTHON_VERSION: "2.7"
- GIT_PATH: "C:\\cygwin64\\bin"
+ GIT_PATH: "C:\\cygwin\\bin"
- PYTHON: "C:\\Miniconda3-x64"
PYTHON_VERSION: "3.4"
- - PYTHON: "C:\\Miniconda3-x64"
+ - PYTHON: "C:\\Python34"
PYTHON_VERSION: "3.4"
GIT_PATH: "C:\\cygwin64\\bin"
@@ -30,9 +30,11 @@ install:
where git
python --version
python -c "import struct; print(struct.calcsize('P') * 8)"
- conda info -a
- - conda install --yes --quiet pip
+ - IF EXIST "%PYTHON%\conda.exe" (
+ conda info -a &
+ conda install --yes --quiet pip
+ )
- pip install nose wheel coveralls
- IF "%PYTHON_VERSION%"=="2.7" (
pip install mock
@@ -60,15 +62,7 @@ install:
build: off
test_script:
- - |
- echo "+++ Checking archives for PyPI repo..."
- python setup.py bdist_wheel
-
- - IF "%PYTHON_VERSION%"=="3.4" (
- nosetests -v --with-coverage
- ) ELSE (
- nosetests -v
- )
+ - "nosetests -v"
#on_success:
# - IF "%PYTHON_VERSION%"=="3.4" (coveralls)
diff --git a/git/test/test_util.py b/git/test/test_util.py
index c6ca6920..a47697c0 100644
--- a/git/test/test_util.py
+++ b/git/test/test_util.py
@@ -90,7 +90,7 @@ class TestUtils(TestBase):
wait_lock = BlockingLockFile(my_file, 0.05, wait_time)
self.failUnlessRaises(IOError, wait_lock._obtain_lock)
elapsed = time.time() - start
- assert elapsed <= wait_time + 0.02 # some extra time it may cost
+ assert elapsed <= wait_time + 0.02, elapsed # some extra time it may cost
def test_user_id(self):
assert '@' in get_user_id()