summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2021-10-13 11:16:27 +0300
committerSebastian Thiel <sebastian.thiel@icloud.com>2021-10-14 15:03:19 +0800
commitb0630030a1d2db994fb2fb488efa167b91594864 (patch)
treee8a80dc332ed53bbca556c0af00fbab7bb6df5f1
parentb17bc980b1546159ceb119f04716f24b043fc3f8 (diff)
downloadgitpython-b0630030a1d2db994fb2fb488efa167b91594864.tar.gz
Add support for Python 3.10
-rw-r--r--.github/workflows/pythonpackage.yml2
-rw-r--r--AUTHORS1
-rwxr-xr-xsetup.py2
3 files changed, 3 insertions, 2 deletions
diff --git a/.github/workflows/pythonpackage.yml b/.github/workflows/pythonpackage.yml
index 4e7aa418..dd1e9a07 100644
--- a/.github/workflows/pythonpackage.yml
+++ b/.github/workflows/pythonpackage.yml
@@ -15,7 +15,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: [3.7, 3.7.5, 3.7.12, 3.8, 3.8.0, 3.8.11, 3.8, 3.9, 3.9.0, 3.9.7] # , "3.10.0-rc.2"]
+ python-version: [3.7, 3.7.5, 3.7.12, 3.8, 3.8.0, 3.8.11, 3.8, 3.9, 3.9.0, 3.9.7, "3.10"]
steps:
- uses: actions/checkout@v2
diff --git a/AUTHORS b/AUTHORS
index 606796d9..55d68181 100644
--- a/AUTHORS
+++ b/AUTHORS
@@ -44,4 +44,5 @@ Contributors are:
-Ram Rachum <ram _at_ rachum.com>
-Alba Mendez <me _at_ alba.sh>
-Robert Westman <robert _at_ byteflux.io>
+-Hugo van Kemenade
Portions derived from other open source works and are clearly marked.
diff --git a/setup.py b/setup.py
index cd1007d7..4f1d0b75 100755
--- a/setup.py
+++ b/setup.py
@@ -122,6 +122,6 @@ setup(
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
- # "Programming Language :: Python :: 3.10"
+ "Programming Language :: Python :: 3.10",
]
)