summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Thiel <sebastian.thiel@icloud.com>2022-05-18 08:01:18 +0800
committerSebastian Thiel <sebastian.thiel@icloud.com>2022-05-18 08:01:18 +0800
commitf78fc42b90711c81e06699d1ebdbe69e6648b949 (patch)
tree6b98bb98890571b5c3b47b7935c5423939a771c2
parent68fca7465366432c18d289bbe4b6e6edbd8962ab (diff)
downloadgitpython-f78fc42b90711c81e06699d1ebdbe69e6648b949.tar.gz
See if black can be tought to produce consistent results
-rw-r--r--.flake82
-rw-r--r--pyproject.toml4
2 files changed, 5 insertions, 1 deletions
diff --git a/.flake8 b/.flake8
index 47d40978..e3d7917a 100644
--- a/.flake8
+++ b/.flake8
@@ -34,5 +34,5 @@ rst-roles = # for flake8-RST-docstrings
min-python-version = 3.7.0
# for `black` compatibility
-max-line-length = 88
+max-line-length = 120
extend-ignore = E203
diff --git a/pyproject.toml b/pyproject.toml
index da3e605a..0d5ebf01 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -39,3 +39,7 @@ source = ["git"]
[tool.coverage.report]
include = ["*/git/*"]
omit = ["*/git/ext/*"]
+
+[tool.black]
+line-length = 120
+target-version = ['py37']