summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Thiel <byronimo@gmail.com>2014-11-15 13:37:56 +0100
committerSebastian Thiel <byronimo@gmail.com>2014-11-15 13:37:56 +0100
commit15c4a95ada66977c8cf80767bf1c72a45eb576b2 (patch)
treefc85951acb541b7e521c3851c35fa081726c581f
parent0441fdcbc4ea1ab8ce5455f2352436712f1b30bb (diff)
parent2ab7ac2397d60f1a71a90bf836543f9e0dcad2d0 (diff)
downloadgitpython-15c4a95ada66977c8cf80767bf1c72a45eb576b2.tar.gz
Merge pull request #203 from hashar/lint-setup_py
Lint setup.py
-rwxr-xr-xsetup.py65
1 files changed, 35 insertions, 30 deletions
diff --git a/setup.py b/setup.py
index e724a129..fd19be5a 100755
--- a/setup.py
+++ b/setup.py
@@ -19,7 +19,9 @@ v.close()
with open('requirements.txt') as reqs_file:
requirements = reqs_file.read().splitlines()
+
class build_py(_build_py):
+
def run(self):
init = path.join(self.build_lib, 'git', '__init__.py')
if path.exists(init):
@@ -30,7 +32,8 @@ class build_py(_build_py):
class sdist(_sdist):
- def make_release_tree (self, base_dir, files):
+
+ def make_release_tree(self, base_dir, files):
_sdist.make_release_tree(self, base_dir, files)
orig = path.join('git', '__init__.py')
assert path.exists(orig), orig
@@ -48,7 +51,7 @@ def _stamp_version(filename):
except (IOError, OSError):
print >> sys.stderr, "Couldn't find file %s to stamp version" % filename
return
- #END handle error, usually happens during binary builds
+ # END handle error, usually happens during binary builds
for line in f:
if '__version__ =' in line:
line = line.replace("'git'", "'%s'" % VERSION)
@@ -63,35 +66,37 @@ def _stamp_version(filename):
else:
print >> sys.stderr, "WARNING: Couldn't find version line in file %s" % filename
-install_requires = ['gitdb >= 0.6.0',]
-setup(name = "GitPython",
- cmdclass={'build_py': build_py, 'sdist': sdist},
- version = VERSION,
- description = "Python Git Library",
- author = "Sebastian Thiel, Michael Trier",
- author_email = "byronimo@gmail.com, mtrier@gmail.com",
- url = "http://gitorious.org/projects/git-python/",
- packages = find_packages('.'),
- py_modules = ['git.'+f[:-3] for f in os.listdir('./git') if f.endswith('.py')],
- package_data = {'git.test' : ['fixtures/*']},
- package_dir = {'git':'git'},
- license = "BSD License",
- requires=['gitdb (>=0.6.0)'],
- install_requires=install_requires,
- test_requirements = ['mock', 'nose'] + install_requires,
- zip_safe=False,
- long_description = """\
+install_requires = ['gitdb >= 0.6.0']
+
+setup(
+ name="GitPython",
+ cmdclass={'build_py': build_py, 'sdist': sdist},
+ version=VERSION,
+ description="Python Git Library",
+ author="Sebastian Thiel, Michael Trier",
+ author_email="byronimo@gmail.com, mtrier@gmail.com",
+ url="http://gitorious.org/projects/git-python/",
+ packages=find_packages('.'),
+ py_modules=['git.'+f[:-3] for f in os.listdir('./git') if f.endswith('.py')],
+ package_data={'git.test': ['fixtures/*']},
+ package_dir={'git': 'git'},
+ license="BSD License",
+ requires=['gitdb (>=0.6.0)'],
+ install_requires=install_requires,
+ test_requirements=['mock', 'nose'] + install_requires,
+ zip_safe=False,
+ long_description="""\
GitPython is a python library used to interact with Git repositories""",
- classifiers=[
- # Picked from
- # http://pypi.python.org/pypi?:action=list_classifiers
- #"Development Status :: 1 - Planning",
- #"Development Status :: 2 - Pre-Alpha",
- #"Development Status :: 3 - Alpha",
+ classifiers=[
+ # Picked from
+ # http://pypi.python.org/pypi?:action=list_classifiers
+ # "Development Status :: 1 - Planning",
+ # "Development Status :: 2 - Pre-Alpha",
+ # "Development Status :: 3 - Alpha",
"Development Status :: 4 - Beta",
# "Development Status :: 5 - Production/Stable",
- #"Development Status :: 6 - Mature",
- #"Development Status :: 7 - Inactive",
+ # "Development Status :: 6 - Mature",
+ # "Development Status :: 7 - Inactive",
"Environment :: Console",
"Intended Audience :: Developers",
"License :: OSI Approved :: BSD License",
@@ -106,5 +111,5 @@ GitPython is a python library used to interact with Git repositories""",
# "Programming Language :: Python :: 3",
# "Programming Language :: Python :: 3.3",
# "Programming Language :: Python :: 3.4",
- ]
- )
+ ]
+)