summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarmon <Harmon758@gmail.com>2020-02-16 14:32:28 -0600
committerHarmon <Harmon758@gmail.com>2020-02-16 14:32:28 -0600
commit9e47352575d9b0a453770114853620e8342662fb (patch)
treef4cd8fcc1a81345d102091c04cf14c2dc562cb1a
parente4a83ff7910dc3617583da7e0965cd48a69bb669 (diff)
downloadgitpython-9e47352575d9b0a453770114853620e8342662fb.tar.gz
Add support for Python 3.8
-rw-r--r--.travis.yml1
-rw-r--r--README.md2
-rwxr-xr-xsetup.py3
-rw-r--r--tox.ini2
4 files changed, 5 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index 65c36d32..c25a55be 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,6 +4,7 @@ python:
- "3.5"
- "3.6"
- "3.7"
+ - "3.8"
- "nightly"
# - "pypy" - won't work as smmap doesn't work (see gitdb/.travis.yml for details)
matrix:
diff --git a/README.md b/README.md
index 032882f5..7e0d8b6a 100644
--- a/README.md
+++ b/README.md
@@ -19,7 +19,7 @@ If it is not in your `PATH`, you can help GitPython find it by setting
the `GIT_PYTHON_GIT_EXECUTABLE=<path/to/git>` environment variable.
* Git (1.7.x or newer)
-* Python 3.4 to 3.7.
+* Python >= 3.4
The list of dependencies are listed in `./requirements.txt` and `./test-requirements.txt`.
The installer takes care of installing them for you.
diff --git a/setup.py b/setup.py
index 488d348e..11a1d6b7 100755
--- a/setup.py
+++ b/setup.py
@@ -105,6 +105,7 @@ setup(
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
- "Programming Language :: Python :: 3.7"
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8"
]
)
diff --git a/tox.ini b/tox.ini
index 36048fbc..df929a76 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py34,py35,py36,py37,flake8
+envlist = py34,py35,py36,py37,py38,flake8
[testenv]
commands = nosetests {posargs}