summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo <hugovk@users.noreply.github.com>2017-12-04 16:54:23 +0200
committerSebastian Thiel <byronimo@gmail.com>2017-12-11 15:24:55 +0100
commitc22f1b05fee73dd212c470fecf29a0df9e25a18f (patch)
tree600b94b42cae82415293925cf0aff28337f68088
parenta14277eecf65ac216dd1b756acee8c23ecdf95d9 (diff)
downloadgitpython-c22f1b05fee73dd212c470fecf29a0df9e25a18f.tar.gz
Specify Python 3.6 support
-rw-r--r--README.md4
-rwxr-xr-xsetup.py1
2 files changed, 3 insertions, 2 deletions
diff --git a/README.md b/README.md
index 45676375..68c7a3c3 100644
--- a/README.md
+++ b/README.md
@@ -19,7 +19,7 @@ If it is not in your `PATH`, you can help GitPython find it by setting
the `GIT_PYTHON_GIT_EXECUTABLE=<path/to/git>` environment variable.
* Git (1.7.x or newer)
-* Python 2.7 to 3.5, while python 2.6 is supported on a *best-effort basis*.
+* Python 2.7 to 3.6, while python 2.6 is supported on a *best-effort basis*.
The list of dependencies are listed in `./requirements.txt` and `./test-requirements.txt`.
The installer takes care of installing them for you.
@@ -125,7 +125,7 @@ Please have a look at the [contributions file][contributing].
### How to verify a release
-Please only use releases from `pypi` as you can verify the respective source
+Please only use releases from `pypi` as you can verify the respective source
tarballs.
This script shows how to verify the tarball was indeed created by the authors of
diff --git a/setup.py b/setup.py
index 585a9e29..47523e03 100755
--- a/setup.py
+++ b/setup.py
@@ -101,6 +101,7 @@ setup(
package_data={'git.test': ['fixtures/*']},
package_dir={'git': 'git'},
license="BSD License",
+ python_requires='>=2.6, !=3.0.*, !=3.1.*, !=3.2.*',
requires=['gitdb2 (>=2.0.0)'],
install_requires=install_requires,
test_requirements=test_requires + install_requires,