summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Trier <mtrier@gmail.com>2010-03-20 11:45:58 -0400
committerMichael Trier <mtrier@gmail.com>2010-03-20 11:45:58 -0400
commit7bfca5efce8988e6070e7284bd409d1a731a3fbc (patch)
tree6f44db816731fd2d698a27d1ca34e5c207eac615
parente3e2c8c14b861b4d4865a9574e812ef9f2609771 (diff)
downloadgitpython-7bfca5efce8988e6070e7284bd409d1a731a3fbc.tar.gz
Many small doc changes pulled in from the 0.1.7RC branch.0.1.7
-rw-r--r--CHANGES16
-rw-r--r--VERSION2
-rw-r--r--doc/Makefile2
-rw-r--r--doc/conf.py6
-rw-r--r--doc/intro.rst6
-rw-r--r--lib/git/commit.py4
-rw-r--r--lib/git/repo.py6
-rw-r--r--lib/git/tree.py4
8 files changed, 23 insertions, 23 deletions
diff --git a/CHANGES b/CHANGES
index c82a3071..c876c97b 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,7 +1,7 @@
=======
CHANGES
=======
-
+
0.1.7
=======
This is a bugfix release and the last of its kind in 0.1.X, as 0.2.X will receive
@@ -16,7 +16,7 @@ General
-------
* The test suite now supports Mock 0.5 and above. The transition between Mock 0.4
0.5 changed the API which required adjustments.
-* Many small enhancements done to the method documentation
+* Many small enhancements done to the method documentation
0.1.6
@@ -152,14 +152,14 @@ Git
* Added support for ``stderr``, ``stdin``, and ``with_status``.
-* ``git_dir`` is now optional in the constructor for ``git.Git``. Git now
+* ``git_dir`` is now optional in the constructor for ``git.Git``. Git now
falls back to ``os.getcwd()`` when git_dir is not specified.
-* add a ``with_exceptions`` keyword argument to git commands.
+* add a ``with_exceptions`` keyword argument to git commands.
``GitCommandError`` is raised when the exit status is non-zero.
-* add support for a ``GIT_PYTHON_TRACE`` environment variable.
- ``GIT_PYTHON_TRACE`` allows us to debug GitPython's usage of git through
+* add support for a ``GIT_PYTHON_TRACE`` environment variable.
+ ``GIT_PYTHON_TRACE`` allows us to debug GitPython's usage of git through
the use of an environment variable.
Tree
@@ -175,8 +175,8 @@ Repo
Tree
----
-* Corrected problem with ``Tree.__div__`` not working with zero length files.
- Removed ``__len__`` override and replaced with size instead. Also made size
+* Corrected problem with ``Tree.__div__`` not working with zero length files.
+ Removed ``__len__`` override and replaced with size instead. Also made size
cach properly. This is a breaking change.
0.1.1
diff --git a/VERSION b/VERSION
index c946ee61..11808190 100644
--- a/VERSION
+++ b/VERSION
@@ -1 +1 @@
-0.1.6
+0.1.7
diff --git a/doc/Makefile b/doc/Makefile
index dbc6dec2..0cf0f75c 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -2,7 +2,7 @@
#
# You can set these variables from the command line.
-SPHINXOPTS =
+SPHINXOPTS = -w errors.txt
SPHINXBUILD = sphinx-build
PAPER =
diff --git a/doc/conf.py b/doc/conf.py
index 42200b8c..6205cbed 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -50,9 +50,9 @@ copyright = u'Copyright (C) 2008-2010 Michael Trier and contributors'
# built documents.
#
# The short X.Y version.
-version = '0.1.6'
+version = '0.1.7'
# The full version, including alpha/beta/rc tags.
-release = '0.1.6'
+release = '0.1.7'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
@@ -116,7 +116,7 @@ html_style = 'default.css'
# Add any paths that contain custom static files (such as style sheets) here,
# relative to this directory. They are copied after the builtin static files,
# so a file named "default.css" will overwrite the builtin "default.css".
-html_static_path = ['static']
+#html_static_path = ['static']
# If not '', a 'Last updated on:' timestamp is inserted at every page bottom,
# using the given strftime format.
diff --git a/doc/intro.rst b/doc/intro.rst
index 555bc4c5..c99e5a4c 100644
--- a/doc/intro.rst
+++ b/doc/intro.rst
@@ -20,7 +20,7 @@ Requirements
.. _Git: http://git-scm.com/
.. _Python Nose: http://code.google.com/p/python-nose/
-.. _Mock by Michael Foord: http://www.voidspace.org.uk/python/mock.html
+.. _Mock by Michael Foord: http://www.voidspace.org.uk/python/mock/
Installing GitPython
====================
@@ -40,7 +40,7 @@ here:
* `setuptools`_
* `install setuptools <http://peak.telecommunity.com/DevCenter/EasyInstall#installation-instructions>`_
-* `pypi <http://pypi.python.org/pypi/SQLAlchemy>`_
+* `pypi <http://pypi.python.org/pypi/GitPython>`_
.. _setuptools: http://peak.telecommunity.com/DevCenter/setuptools
@@ -69,7 +69,7 @@ Source Code
GitPython's git repo is available on Gitorious, which can be browsed at:
-http://gitorious.org/projects/git-python/
+http://gitorious.org/git-python
and cloned from:
diff --git a/lib/git/commit.py b/lib/git/commit.py
index 591fb38b..b074d3a8 100644
--- a/lib/git/commit.py
+++ b/lib/git/commit.py
@@ -115,7 +115,7 @@ class Commit(LazyMixin):
is the ref from which to begin (SHA1 or name)
``path``
- is an optinal path
+ is an optional path
Returns
int
@@ -212,7 +212,7 @@ class Commit(LazyMixin):
git.Diff[]::
between tree and the index if only a is given
- between two trees if a and b are given and are commits
+ between two trees if a and b are given and are commits
"""
paths = paths or []
diff --git a/lib/git/repo.py b/lib/git/repo.py
index 3490499c..cfc0913d 100644
--- a/lib/git/repo.py
+++ b/lib/git/repo.py
@@ -161,11 +161,11 @@ class Repo(object):
is the branch/commit name (default 'master')
``path``
- is an optinal path to limit the returned commits to.
+ is an optional path to limit the returned commits to.
``since``
- is a string represeting a date/time
+ is a string representing a date/time
Returns
``git.Commit[]``
@@ -494,7 +494,7 @@ class Repo(object):
"""
if self.bare:
# Bare repositories with no associated working directory are
- # always consired to be clean.
+ # always considered to be clean.
return False
return len(self.git.diff('HEAD', '--').strip()) > 0
diff --git a/lib/git/tree.py b/lib/git/tree.py
index aaeca828..02266dce 100644
--- a/lib/git/tree.py
+++ b/lib/git/tree.py
@@ -64,9 +64,9 @@ class Tree(LazyMixin):
Examples::
- >>> Repo('/path/to/python-git').tree/'lib'
+ >>> Repo('/path/to/python-git').tree()/'lib'
<git.Tree "6cc23ee138be09ff8c28b07162720018b244e95e">
- >>> Repo('/path/to/python-git').tree/'README.txt'
+ >>> Repo('/path/to/python-git').tree()/'README'
<git.Blob "8b1e02c0fb554eed2ce2ef737a68bb369d7527df">
Returns