summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn L. Villalovos <john@sodarock.com>2021-11-24 21:15:45 -0800
committerJohn L. Villalovos <john@sodarock.com>2021-12-05 22:10:29 -0800
commita86d0490cadfc2f9fe5490879a1258cf264d5202 (patch)
tree4054a5c01db6841a470e01caa76ebbfc2f74982c
parentab841b8c63183ca20b866818ab2f930a5643ba5f (diff)
downloadgitlab-a86d0490cadfc2f9fe5490879a1258cf264d5202.tar.gz
chore: enable subset of the 'mypy --strict' options that work
Enable the subset of the 'mypy --strict' options that work with no changes to the code.
-rw-r--r--pyproject.toml18
1 files changed, 17 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 3e81169..8e9920e 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -4,9 +4,25 @@ multi_line_output = 3
order_by_type = false
[tool.mypy]
+files = "."
+
+# 'strict = true' is equivalent to the following:
+check_untyped_defs = true
disallow_incomplete_defs = true
+disallow_subclassing_any = true
+disallow_untyped_decorators = true
disallow_untyped_defs = true
-files = "."
+warn_unused_configs = true
+warn_unused_ignores = true
+
+# The following need to have changes made to be able to enable them:
+# disallow_any_generics = true
+# disallow_untyped_calls = true
+# no_implicit_optional = true
+# no_implicit_reexport = true
+# strict_equality = true
+# warn_redundant_casts = true
+# warn_return_any = true
[[tool.mypy.overrides]] # Overrides for currently untyped modules
module = [