summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn L. Villalovos <john@sodarock.com>2022-06-05 12:53:55 -0700
committerJohn L. Villalovos <john@sodarock.com>2022-06-05 12:53:55 -0700
commit7f2240f1b9231e8b856706952ec84234177a495b (patch)
treecf256b0aa3b63066aa23154fcb8809098b271872
parent7a5923c8e77a41cb829a086a903aee4123ca4d14 (diff)
downloadgitlab-7f2240f1b9231e8b856706952ec84234177a495b.tar.gz
chore: use multiple processors when running PyLint
Use multiple processors when running PyLint. On my system it took about 10.3 seconds to run PyLint before this change. After this change it takes about 5.8 seconds to run PyLint.
-rw-r--r--pyproject.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index fc6c1ec..8912199 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -45,6 +45,7 @@ commit_message = ""
[tool.pylint.messages_control]
max-line-length = 88
+jobs = 0 # Use auto-detected number of multiple processes to speed up Pylint.
# TODO(jlvilla): Work on removing these disables over time.
disable = [
"arguments-differ",