summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xpython2/setup.py18
-rwxr-xr-xpython3/setup.py18
2 files changed, 36 insertions, 0 deletions
diff --git a/python2/setup.py b/python2/setup.py
new file mode 100755
index 0000000..686fd29
--- /dev/null
+++ b/python2/setup.py
@@ -0,0 +1,18 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+
+setup(name='futures',
+ version='0.1',
+ description='Java-style futures implementation in Python',
+ author='Brian Quinlan',
+ author_email='brian@sweetapp.com',
+ url='http://code.google.com/p/pythonfutures',
+ download_url='http://pypi.python.org/pypi/futures/',
+ packages=['futures'],
+ license='BSD',
+ classifiers=['License :: OSI Approved :: BSD License',
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: Developers',
+ 'Programming Language :: Python']
+ )
diff --git a/python3/setup.py b/python3/setup.py
new file mode 100755
index 0000000..e7cff77
--- /dev/null
+++ b/python3/setup.py
@@ -0,0 +1,18 @@
+#!/usr/bin/env python3
+
+from distutils.core import setup
+
+setup(name='futures',
+ version='0.1',
+ description='Java-style futures implementation in Python',
+ author='Brian Quinlan',
+ author_email='brian@sweetapp.com',
+ url='http://code.google.com/p/pythonfutures',
+ download_url='http://pypi.python.org/pypi/futures/',
+ packages=['futures'],
+ license='BSD',
+ classifiers=['License :: OSI Approved :: BSD License',
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: Developers',
+ 'Programming Language :: Python']
+ )