summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrian.quinlan <devnull@localhost>2009-06-11 20:03:23 +0000
committerbrian.quinlan <devnull@localhost>2009-06-11 20:03:23 +0000
commite59ad946c45f9b2d6cbeb3d1df94f4ebb8a4a107 (patch)
tree48c4afd7e44b5fb0b5f8cd53c27361fdd2d88529
parent89f7c0c3b00ce97fb3c59bafe7ece806f79c3a14 (diff)
downloadfutures-e59ad946c45f9b2d6cbeb3d1df94f4ebb8a4a107.tar.gz
Added setup scripts.
-rwxr-xr-xpython2/setup.py18
-rwxr-xr-xpython3/setup.py18
2 files changed, 36 insertions, 0 deletions
diff --git a/python2/setup.py b/python2/setup.py
new file mode 100755
index 0000000..686fd29
--- /dev/null
+++ b/python2/setup.py
@@ -0,0 +1,18 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+
+setup(name='futures',
+ version='0.1',
+ description='Java-style futures implementation in Python',
+ author='Brian Quinlan',
+ author_email='brian@sweetapp.com',
+ url='http://code.google.com/p/pythonfutures',
+ download_url='http://pypi.python.org/pypi/futures/',
+ packages=['futures'],
+ license='BSD',
+ classifiers=['License :: OSI Approved :: BSD License',
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: Developers',
+ 'Programming Language :: Python']
+ )
diff --git a/python3/setup.py b/python3/setup.py
new file mode 100755
index 0000000..e7cff77
--- /dev/null
+++ b/python3/setup.py
@@ -0,0 +1,18 @@
+#!/usr/bin/env python3
+
+from distutils.core import setup
+
+setup(name='futures',
+ version='0.1',
+ description='Java-style futures implementation in Python',
+ author='Brian Quinlan',
+ author_email='brian@sweetapp.com',
+ url='http://code.google.com/p/pythonfutures',
+ download_url='http://pypi.python.org/pypi/futures/',
+ packages=['futures'],
+ license='BSD',
+ classifiers=['License :: OSI Approved :: BSD License',
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: Developers',
+ 'Programming Language :: Python']
+ )