summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2011-06-23 20:21:10 +1200
committerRobert Collins <robertc@robertcollins.net>2011-06-23 20:21:10 +1200
commit063ea50a5a85d7eba578b98d5d482cc51d31d178 (patch)
treeebf8b94e636993f64cb49734a351d70dd50e2ffb
parent2fb7b0381ef2d6aec18cb278ab3ed3becc4d780d (diff)
downloadfixtures-063ea50a5a85d7eba578b98d5d482cc51d31d178.tar.gz
Release 0.3.6.
-rw-r--r--NEWS3
-rw-r--r--lib/fixtures/__init__.py2
-rwxr-xr-xsetup.py2
3 files changed, 5 insertions, 2 deletions
diff --git a/NEWS b/NEWS
index 54c4511..20f2b06 100644
--- a/NEWS
+++ b/NEWS
@@ -6,6 +6,9 @@ fixtures release notes
IN DEVELOPMENT
~~~~~~~~~~~~~~
+0.3.6
+~~~~~
+
Another small API break - sorry. Fixture.getDetails no longer returns the
internal details dict (self._details). Access that directly if needed. It now
looks for details in used fixtures and returns those as well as details added
diff --git a/lib/fixtures/__init__.py b/lib/fixtures/__init__.py
index a697680..8f41e53 100644
--- a/lib/fixtures/__init__.py
+++ b/lib/fixtures/__init__.py
@@ -36,7 +36,7 @@ Most users will want to look at TestWithFixtures and Fixture, to start with.
# established at this point, and setup.py will use a version of next-$(revno).
# If the releaselevel is 'final', then the tarball will be major.minor.micro.
# Otherwise it is major.minor.micro~$(revno).
-__version__ = (0, 3, 5, 'final', 0)
+__version__ = (0, 3, 6, 'final', 0)
__all__ = [
'EnvironmentVariableFixture',
diff --git a/setup.py b/setup.py
index 7cb769b..3489e8a 100755
--- a/setup.py
+++ b/setup.py
@@ -6,7 +6,7 @@ import os.path
description = file(os.path.join(os.path.dirname(__file__), 'README'), 'rb').read()
setup(name="fixtures",
- version="0.3.5",
+ version="0.3.6",
description="Fixtures, reusable state for writing clean tests and more.",
long_description=description,
maintainer="Robert Collins",