summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2012-12-11 14:18:09 +1300
committerRobert Collins <robertc@robertcollins.net>2012-12-11 14:18:09 +1300
commitf1441f4d1cabebbe0664bd9d10cf032f54e90158 (patch)
tree47ec3a0c78bd130d9a13fa0409a5441b2f993ecc
parentb16be6d13a702224432e9836ef2d5b23c765d34e (diff)
downloadfixtures-f1441f4d1cabebbe0664bd9d10cf032f54e90158.tar.gz
Release 0.3.10.
-rw-r--r--NEWS3
-rw-r--r--lib/fixtures/__init__.py2
-rwxr-xr-xsetup.py3
3 files changed, 6 insertions, 2 deletions
diff --git a/NEWS b/NEWS
index 5839f64..3c802a8 100644
--- a/NEWS
+++ b/NEWS
@@ -6,6 +6,9 @@ fixtures release notes
NEXT
~~~~
+0.3.10
+~~~~~~
+
New ``DetailStream`` fixture to add file-like object content to testtools
details, cleanup logic factored out into a CallMany class.
diff --git a/lib/fixtures/__init__.py b/lib/fixtures/__init__.py
index 9b9d3b6..89009cc 100644
--- a/lib/fixtures/__init__.py
+++ b/lib/fixtures/__init__.py
@@ -36,7 +36,7 @@ Most users will want to look at TestWithFixtures and Fixture, to start with.
# established at this point, and setup.py will use a version of next-$(revno).
# If the releaselevel is 'final', then the tarball will be major.minor.micro.
# Otherwise it is major.minor.micro~$(revno).
-__version__ = (0, 3, 9, 'final', 0)
+__version__ = (0, 3, 10, 'final', 0)
__all__ = [
'DetailStream',
diff --git a/setup.py b/setup.py
index 86f64f4..cfe9031 100755
--- a/setup.py
+++ b/setup.py
@@ -6,8 +6,9 @@ import os.path
description = file(os.path.join(os.path.dirname(__file__), 'README'), 'rb').read()
setup(name="fixtures",
- version="0.3.9",
+ version="0.3.10",
description="Fixtures, reusable state for writing clean tests and more.",
+ keywords="fixture fixtures unittest contextmanager",
long_description=description,
maintainer="Robert Collins",
maintainer_email="robertc@robertcollins.net",