summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2013-08-16 12:53:51 +1200
committerRobert Collins <robertc@robertcollins.net>2013-08-16 12:53:51 +1200
commitf0e8391efaf1b2143fac94647bdf3ccad91cb13e (patch)
treec2d102d17fc839fb248a43edfae1b3a902558d44
parent9659b22fcc17420abaa946125e1c723c377fc46e (diff)
downloadfixtures-f0e8391efaf1b2143fac94647bdf3ccad91cb13e.tar.gz
Release 0.3.130.3.13
-rw-r--r--HACKING12
-rw-r--r--NEWS3
-rw-r--r--lib/fixtures/__init__.py2
-rwxr-xr-xsetup.py2
4 files changed, 17 insertions, 2 deletions
diff --git a/HACKING b/HACKING
index 829dc42..e23d297 100644
--- a/HACKING
+++ b/HACKING
@@ -35,3 +35,15 @@ The ``fixtures`` module should simply import classes and functions from
more specific modules, rather than becoming large and bloated itself. For
instance, TestWithFixtures lives in fixtures.testcase, and is imported in
the fixtures __init__.py.
+
+Releasing
++++++++++
+
+1. Update the version number in __init__.py and setup.py and add a version to
+ NEWS.
+
+1. Upload to pypi, signed.
+
+1. commit, tag.
+
+1. Close bugs.
diff --git a/NEWS b/NEWS
index ec8b38f..c7b9656 100644
--- a/NEWS
+++ b/NEWS
@@ -6,6 +6,9 @@ fixtures release notes
NEXT
~~~~
+0.3.13
+~~~~~~
+
CHANGES
-------
diff --git a/lib/fixtures/__init__.py b/lib/fixtures/__init__.py
index f2d9a2f..0995daa 100644
--- a/lib/fixtures/__init__.py
+++ b/lib/fixtures/__init__.py
@@ -36,7 +36,7 @@ Most users will want to look at TestWithFixtures and Fixture, to start with.
# established at this point, and setup.py will use a version of next-$(revno).
# If the releaselevel is 'final', then the tarball will be major.minor.micro.
# Otherwise it is major.minor.micro~$(revno).
-__version__ = (0, 3, 12, 'final', 0)
+__version__ = (0, 3, 13, 'final', 0)
__all__ = [
'ByteStream',
diff --git a/setup.py b/setup.py
index e772ab4..6f973a8 100755
--- a/setup.py
+++ b/setup.py
@@ -6,7 +6,7 @@ import os.path
description = open(os.path.join(os.path.dirname(__file__), 'README'), 'rt').read()
setup(name="fixtures",
- version="0.3.12",
+ version="0.3.13",
description="Fixtures, reusable state for writing clean tests and more.",
keywords="fixture fixtures unittest contextmanager",
long_description=description,