summaryrefslogtreecommitdiff
path: root/tools
diff options
context:
space:
mode:
authormilde <milde@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>2010-09-21 12:51:29 +0000
committermilde <milde@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>2010-09-21 12:51:29 +0000
commitdd5b12161f33e29b0c1bf09e8207728326a6e7d7 (patch)
tree8ce4c24da05e8df37c762c27f9866380de01e118 /tools
parent7d4557038f0838df5e03cb4d1cb6d6c724a3759c (diff)
downloaddocutils-dd5b12161f33e29b0c1bf09e8207728326a6e7d7.tar.gz
XeTeX writer update/bugfix/completion
rst2xetex.py front end, install xetex writer with setup.py, no hyphenation in literal text. git-svn-id: http://svn.code.sf.net/p/docutils/code/trunk/docutils@6431 929543f6-e4f2-0310-98a6-ba3bd3dd1d04
Diffstat (limited to 'tools')
-rwxr-xr-xtools/rst2xetex.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/tools/rst2xetex.py b/tools/rst2xetex.py
new file mode 100755
index 000000000..277315a08
--- /dev/null
+++ b/tools/rst2xetex.py
@@ -0,0 +1,27 @@
+#!/usr/bin/env python
+# .. coding: utf8
+
+# $Id$
+# Author: Günter Milde
+# Copyright: This module has been placed in the public domain.
+
+"""
+A minimal front end to the Docutils Publisher, producing XeLaTeX source code.
+"""
+
+try:
+ import locale
+ locale.setlocale(locale.LC_ALL, '')
+except:
+ pass
+
+from docutils.core import publish_cmdline
+
+description = ('Generates XeLaTeX documents from standalone reStructuredText '
+ 'sources. '
+ 'Reads from <source> (default is stdin) and writes to '
+ '<destination> (default is stdout). See '
+ '<http://docutils.sourceforge.net/docs/user/latex.html> for '
+ 'the full reference.')
+
+publish_cmdline(writer_name='xetex', description=description)