summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorwiemann <wiemann@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>2006-01-07 23:58:10 +0000
committerwiemann <wiemann@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>2006-01-07 23:58:10 +0000
commit6865d1b2e0c9d83f02c774a6d66ae28f75fd72bf (patch)
tree864680f1657bd045bcff3659e455d6b8f313bc4c /setup.py
parent562296b27435796aba23dc1f98558fd655b90bee (diff)
downloaddocutils-6865d1b2e0c9d83f02c774a6d66ae28f75fd72bf.tar.gz
Py21/Py22 fix: install data_files to /usr/lib/python-2.x/site-packages instead of /usr/docutils
git-svn-id: http://svn.code.sf.net/p/docutils/code/trunk/docutils@4246 929543f6-e4f2-0310-98a6-ba3bd3dd1d04
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py17
1 files changed, 4 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index 2e502e1c3..0df04c62b 100755
--- a/setup.py
+++ b/setup.py
@@ -10,18 +10,6 @@ from distutils.command.build_py import build_py
from distutils.command.install_data import install_data
-class smart_install_data(install_data):
-
- # From <http://wiki.python.org/moin/DistutilsInstallDataScattered>,
- # by Pete Shinners.
-
- def run(self):
- #need to change self.install_dir to the library dir
- install_cmd = self.get_finalized_command('install')
- self.install_dir = getattr(install_cmd, 'install_lib')
- return install_data.run(self)
-
-
def do_setup():
kwargs = package_data.copy()
extras = get_extras()
@@ -54,7 +42,6 @@ what-you-see-is-what-you-get plaintext markup syntax.""", # wrap at col 60
'author_email': 'goodger@users.sourceforge.net',
'license': 'public domain, Python, BSD, GPL (see COPYING.txt)',
'platforms': 'OS-independent',
- 'cmdclass': {'install_data': smart_install_data},
'package_dir': {'docutils': 'docutils', '': 'extras'},
'packages': ['docutils',
'docutils.languages',
@@ -164,4 +151,8 @@ class dual_build_py(build_py):
if __name__ == '__main__' :
+ # From <http://groups.google.de/groups?as_umsgid=f70e3538.0404141327.6cea58ca@posting.google.com>.
+ from distutils.command.install import INSTALL_SCHEMES
+ for scheme in INSTALL_SCHEMES.values():
+ scheme['data'] = scheme['purelib']
do_setup()