summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorBob Halley <halley@dnspython.org>2020-05-01 08:32:57 -0700
committerBob Halley <halley@dnspython.org>2020-05-01 08:32:57 -0700
commit035598d16b21c5716b55ceb2583437219298ebbc (patch)
tree35eec32ac97ca5e8d6e56b95724c35074a583ee7 /pyproject.toml
parent1aebd5b2f0e2145ec2ee33f3996b0175ce24f025 (diff)
downloaddnspython-035598d16b21c5716b55ceb2583437219298ebbc.tar.gz
start poetry and pyenv support
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..9ab6cc7
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,21 @@
+[tool.poetry]
+name = "dnspython"
+version = "2.0.0"
+description = "DNS toolkit"
+authors = ["Bob Halley <halley@dnspython.org>"]
+license = "ISC"
+
+[tool.poetry.dependencies]
+python = "^3.5"
+requests-toolbelt = "^0.9.1"
+requests = "^2.23.0"
+idna = "^2.1"
+cryptography = "^2.6"
+
+[tool.poetry.dev-dependencies]
+mypy = "^0.770"
+pylint = "^2.5.0"
+
+[build-system]
+requires = ["poetry>=0.12"]
+build-backend = "poetry.masonry.api"