summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Halley <halley@dnspython.org>2005-10-31 07:35:33 +0000
committerBob Halley <halley@dnspython.org>2005-10-31 07:35:33 +0000
commite3aaf7139bd44843f3a062e1efd63c8fbf428bed (patch)
tree84fb182e5b1ec0c3f32cf520628ef901ff58ba71
parenta83615f439aec63f37198324260eac7f61f46d1c (diff)
downloaddnspython-e3aaf7139bd44843f3a062e1efd63c8fbf428bed.tar.gz
prep 1.3.5
-rw-r--r--ChangeLog4
-rw-r--r--README30
-rw-r--r--dns/version.py2
-rwxr-xr-xsetup.py2
4 files changed, 35 insertions, 3 deletions
diff --git a/ChangeLog b/ChangeLog
index 330bf1c..b4cef23 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2005-10-31 Bob Halley <halley@dnspython.org>
+
+ * (Version 1.3.5 released)
+
2005-10-12 Bob Halley <halley@dnspython.org>
* dns/zone.py: Zone.iterate_rdatasets() and Zone.iterate_rdatas()
diff --git a/README b/README
index 1ca7b55..fe54398 100644
--- a/README
+++ b/README
@@ -22,7 +22,35 @@ development by continuing to employ the author :).
ABOUT THIS RELEASE
-This is dnspython 1.3.4
+This is dnspython 1.3.5
+
+New since 1.3.4:
+
+ In the resolver, if time goes backward a little bit, ignore
+ it.
+
+ zone_for_name() has been added to the resolver module. It
+ returns the zone which is authoritative for the specified
+ name, which is handy for dynamic update. E.g.
+
+ import dns.resolver
+ print dns.resolver.zone_for_name('www.dnspython.org')
+
+ will output "dnspython.org." and
+
+ print dns.resolver.zone_for_name('a.b.c.d.e.f.example.')
+
+ will output ".".
+
+ The default resolver can be fetched with the
+ get_default_resolver() method.
+
+ You can now get the parent (immediate superdomain) of a name
+ by using the parent() method.
+
+ Zone.iterate_rdatasets() and Zone.iterate_rdatas() now have
+ a default rdtype of dns.rdatatype.ANY like the documentation
+ says.
New since 1.3.3:
diff --git a/dns/version.py b/dns/version.py
index da4677b..bce0595 100644
--- a/dns/version.py
+++ b/dns/version.py
@@ -17,7 +17,7 @@
MAJOR = 1
MINOR = 3
-MICRO = 4
+MICRO = 5
RELEASELEVEL = 0x0f
SERIAL = 0
diff --git a/setup.py b/setup.py
index fd744ff..297d021 100755
--- a/setup.py
+++ b/setup.py
@@ -19,7 +19,7 @@ from distutils.core import setup
setup(
name = "dnspython",
- version = "1.3.4",
+ version = "1.3.5",
description = "DNS toolkit",
long_description = \
"""dnspython is a DNS toolkit for Python. It supports almost all