summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Halley <halley@dnspython.org>2006-09-29 23:17:45 +0000
committerBob Halley <halley@dnspython.org>2006-09-29 23:17:45 +0000
commit506641ed3ecd77e5408a9d37f1a91d7a18e87446 (patch)
treedc8f280b6a7f529ca092929e1f128843b8fb9418
parentb63a9706bab8927cfca711ce0d614a7b1c5530db (diff)
downloaddnspython-506641ed3ecd77e5408a9d37f1a91d7a18e87446.tar.gz
add python 2.5 distutils metadata
-rwxr-xr-xsetup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 5b6d6ee..1c29646 100755
--- a/setup.py
+++ b/setup.py
@@ -55,4 +55,8 @@ if sys.hexversion >= 0x02020300:
"Topic :: Software Development :: Libraries :: Python Modules",
]
+if sys.hexversion >= 0x02050000:
+ kwargs['requires'] = []
+ kwargs['provides'] = ['dns']
+
setup(**kwargs)