diff options
author | Bob Halley <halley@dnspython.org> | 2005-09-02 05:33:11 +0000 |
---|---|---|
committer | Bob Halley <halley@dnspython.org> | 2005-09-02 05:33:11 +0000 |
commit | 2725c6e088dde47521fb27dd4d717ed661be8282 (patch) | |
tree | 91590bea092df35592eb56db335f827e1c762d51 | |
parent | e1f4089657749ee3b825ab1a93a6e0c82c04ab34 (diff) | |
download | dnspython-2725c6e088dde47521fb27dd4d717ed661be8282.tar.gz |
prep 1.3.4
Original author: Bob Halley <halley@dnspython.org>
Date: 2005-06-05 16:49:40
-rw-r--r-- | ChangeLog | 14 | ||||
-rw-r--r-- | README | 14 | ||||
-rw-r--r-- | dns/version.py | 2 | ||||
-rwxr-xr-x | setup.py | 2 |
4 files changed, 29 insertions, 3 deletions
@@ -1,3 +1,17 @@ +2005-06-05 Bob Halley <halley@nominum.com> + + * dns/query.py: The requirement that the "where" parameter be + an IPv4 or IPv6 address is now documented. + +2005-06-04 Bob Halley <halley@nominum.com> + + * dns/resolver.py: The resolver now does exponential backoff + each time it runs through all of the nameservers. + + * dns/resolver.py: rcodes which indicate a nameserver is likely + to be a "permanent failure" for a query cause the nameserver + to be removed from the mix for that query. + 2005-01-30 Bob Halley <halley@dnspython.org> * (Version 1.3.3 released) @@ -22,7 +22,19 @@ development by continuing to employ the author :). ABOUT THIS RELEASE -This is dnspython 1.3.3. +This is dnspython 1.3.4. + +New since 1.3.3: + + The requirement that the "where" parameter in dns.query.{udp,tcp,xfr} + be an IPv4 or IPv6 address is now documented. + + The resolver now does exponential backoff each time it runs + through all of the nameservers. + + Rcodes which indicate a nameserver is likely to be a + "permanent failure" for a query cause the nameserver to be removed + from the mix for that query. New since 1.3.2: diff --git a/dns/version.py b/dns/version.py index 269e07f..da4677b 100644 --- a/dns/version.py +++ b/dns/version.py @@ -17,7 +17,7 @@ MAJOR = 1 MINOR = 3 -MICRO = 3 +MICRO = 4 RELEASELEVEL = 0x0f SERIAL = 0 @@ -19,7 +19,7 @@ from distutils.core import setup setup( name = "dnspython", - version = "1.3.3", + version = "1.3.4", description = "DNS toolkit", long_description = \ """dnspython is a DNS toolkit for Python. It supports almost all |