summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Halley <halley@dnspython.org>2005-09-02 05:33:11 +0000
committerBob Halley <halley@dnspython.org>2005-09-02 05:33:11 +0000
commit2725c6e088dde47521fb27dd4d717ed661be8282 (patch)
tree91590bea092df35592eb56db335f827e1c762d51
parente1f4089657749ee3b825ab1a93a6e0c82c04ab34 (diff)
downloaddnspython-2725c6e088dde47521fb27dd4d717ed661be8282.tar.gz
prep 1.3.4
Original author: Bob Halley <halley@dnspython.org> Date: 2005-06-05 16:49:40
-rw-r--r--ChangeLog14
-rw-r--r--README14
-rw-r--r--dns/version.py2
-rwxr-xr-xsetup.py2
4 files changed, 29 insertions, 3 deletions
diff --git a/ChangeLog b/ChangeLog
index 33469b1..81d5263 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,17 @@
+2005-06-05 Bob Halley <halley@nominum.com>
+
+ * dns/query.py: The requirement that the "where" parameter be
+ an IPv4 or IPv6 address is now documented.
+
+2005-06-04 Bob Halley <halley@nominum.com>
+
+ * dns/resolver.py: The resolver now does exponential backoff
+ each time it runs through all of the nameservers.
+
+ * dns/resolver.py: rcodes which indicate a nameserver is likely
+ to be a "permanent failure" for a query cause the nameserver
+ to be removed from the mix for that query.
+
2005-01-30 Bob Halley <halley@dnspython.org>
* (Version 1.3.3 released)
diff --git a/README b/README
index a610c3a..2ca957c 100644
--- a/README
+++ b/README
@@ -22,7 +22,19 @@ development by continuing to employ the author :).
ABOUT THIS RELEASE
-This is dnspython 1.3.3.
+This is dnspython 1.3.4.
+
+New since 1.3.3:
+
+ The requirement that the "where" parameter in dns.query.{udp,tcp,xfr}
+ be an IPv4 or IPv6 address is now documented.
+
+ The resolver now does exponential backoff each time it runs
+ through all of the nameservers.
+
+ Rcodes which indicate a nameserver is likely to be a
+ "permanent failure" for a query cause the nameserver to be removed
+ from the mix for that query.
New since 1.3.2:
diff --git a/dns/version.py b/dns/version.py
index 269e07f..da4677b 100644
--- a/dns/version.py
+++ b/dns/version.py
@@ -17,7 +17,7 @@
MAJOR = 1
MINOR = 3
-MICRO = 3
+MICRO = 4
RELEASELEVEL = 0x0f
SERIAL = 0
diff --git a/setup.py b/setup.py
index 76e12d6..fd744ff 100755
--- a/setup.py
+++ b/setup.py
@@ -19,7 +19,7 @@ from distutils.core import setup
setup(
name = "dnspython",
- version = "1.3.3",
+ version = "1.3.4",
description = "DNS toolkit",
long_description = \
"""dnspython is a DNS toolkit for Python. It supports almost all