summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Halley <halley@dnspython.org>2013-09-02 12:00:41 -0700
committerBob Halley <halley@dnspython.org>2013-09-02 12:00:41 -0700
commit5797467e6da346666381687971707b47ac9e933d (patch)
tree706eb338e50f1a9f028ed47ea78e10c369e68c45
parent6ff1bebe62e64093086d820a972920ecad2acae4 (diff)
downloaddnspython-5797467e6da346666381687971707b47ac9e933d.tar.gz
prep 1.11.1v1.11.1
-rw-r--r--ChangeLog33
-rw-r--r--README23
-rw-r--r--dns/version.py2
-rwxr-xr-xsetup.py2
4 files changed, 54 insertions, 6 deletions
diff --git a/ChangeLog b/ChangeLog
index 4cfcf8f..5537eb9 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,9 +1,36 @@
+2013-09-02 Bob Halley <halley@dnspython.org>
+
+ * (Version 1.11.1 released)
+
+2013-09-01 Bob Halley <halley@dnspython.org>
+
+ * dns/tsigkeyring.py (to_text): we want keyname.to_text(), not
+ dns.name.to_text(keyname). Thangs to wangwang for the fix.
+
2013-08-26 Bob Halley <halley@dnspython.org>
* dns/tsig.py (sign): multi-message TSIGs were broken for
- algorithms other than HMAC-MD5 because we weren't passing the
- right digest module to the HMAC code. Thanks to salzmdan for
- reporting the bug.
+ algorithms other than HMAC-MD5 because we weren't passing the
+ right digest module to the HMAC code. Thanks to salzmdan for
+ reporting the bug.
+
+2013-08-09 Bob Halley <halley@dnspython.org>
+
+ * dns/dnssec.py (_find_candidate_keys): we tried to extract the
+ key from the wrong variable name. Thanks to Andrei Fokau for the
+ fix.
+
+2013-07-08 Bob Halley <halley@dnspython.org>
+
+ * dns/resolver.py: we want 'self.retry_servfail' not just
+ retry_servfail. Reported by many, thanks! Thanks to
+ Jeffrey C. Ollie for the fix.
+
+2013-07-08 Bob Halley <halley@dnspython.org>
+
+ * tests/grange.py: fix tests to use older-style print formatting
+ for backwards compatibility with python 2.4. Thanks to
+ Jeffrey C. Ollie for the fix.
2013-07-01 Bob Halley <halley@dnspython.org>
diff --git a/README b/README
index f74686d..53518f4 100644
--- a/README
+++ b/README
@@ -22,7 +22,28 @@ development by continuing to employ the author :).
ABOUT THIS RELEASE
-This is dnspython 1.11.0
+This is dnspython 1.11.1
+
+New since 1.11.0:
+
+ Nothing
+
+Bugs fixed since 1.11.1:
+
+ dns.resolver.Resolver erroneously referred to 'retry_servfail'
+ instead of 'self.retry_servfail'.
+
+ dns.tsigkeyring.to_text() would fail trying to convert the
+ keyname to text.
+
+ Multi-message TSIGs were broken for algorithms other than
+ HMAC-MD5 because we weren't passing the right digest module to
+ the HMAC code.
+
+ dns.dnssec._find_candidate_keys() tried to extract the key
+ from the wrong variable name.
+
+ $GENERATE tests were not backward compatible with python 2.4.
New since 1.10.0:
diff --git a/dns/version.py b/dns/version.py
index 7f393be..c3d305e 100644
--- a/dns/version.py
+++ b/dns/version.py
@@ -17,7 +17,7 @@
MAJOR = 1
MINOR = 11
-MICRO = 0
+MICRO = 1
RELEASELEVEL = 0x0f
SERIAL = 0
diff --git a/setup.py b/setup.py
index a6e45a2..d431c3e 100755
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,7 @@
import sys
from distutils.core import setup
-version = '1.11.0'
+version = '1.11.1'
kwargs = {
'name' : 'dnspython',