summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorMalcolm Tredinnick <malcolm.tredinnick@gmail.com>2007-02-12 00:33:24 +0000
committerMalcolm Tredinnick <malcolm.tredinnick@gmail.com>2007-02-12 00:33:24 +0000
commit22587230977e862a7e87723d538b5b5e48800494 (patch)
tree11e01b7a62d56c952ab52b1c2552dde4d0a24ac1 /scripts
parenta0c354ee4ed02bb3f958dfb029d29b76e6637952 (diff)
downloaddjango-22587230977e862a7e87723d538b5b5e48800494.tar.gz
Refs #3338 -- Partially fix rpm packaging problems. There is still one issue
remaining with how we construct the version numbers, but this change is useful nonetheless. Patch from Dirk Datzert. git-svn-id: http://code.djangoproject.com/svn/django/trunk@4490 bcc190cf-cafb-0310-a4f2-bffc1f526a37
Diffstat (limited to 'scripts')
-rw-r--r--scripts/rpm-install.sh19
1 files changed, 19 insertions, 0 deletions
diff --git a/scripts/rpm-install.sh b/scripts/rpm-install.sh
new file mode 100644
index 0000000000..07a087c447
--- /dev/null
+++ b/scripts/rpm-install.sh
@@ -0,0 +1,19 @@
+#! /bin/sh
+#
+# this file is *inserted* into the install section of the generated
+# spec file
+#
+
+# this is, what dist.py normally does
+python setup.py install --root=${RPM_BUILD_ROOT} --record="INSTALLED_FILES"
+
+for i in `cat INSTALLED_FILES`; do
+ if [ -f ${RPM_BUILD_ROOT}/$i ]; then
+ echo $i >>FILES
+ fi
+ if [ -d ${RPM_BUILD_ROOT}/$i ]; then
+ echo %dir $i >>DIRS
+ fi
+done
+
+cat DIRS FILES >INSTALLED_FILES