summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMariusz Felisiak <felisiak.mariusz@gmail.com>2020-10-13 08:35:01 +0200
committerMariusz Felisiak <felisiak.mariusz@gmail.com>2020-10-13 08:40:39 +0200
commit301bca9394cd977bc085c5cc50bd0ef9f6af52d7 (patch)
tree50fd0614607a17ba016b8d486d3b5a61935d32c3
parent9deb850e234ea52ac230916b6edd5d4889449e55 (diff)
downloaddjango-301bca9394cd977bc085c5cc50bd0ef9f6af52d7.tar.gz
[3.0.x] Refs #31040 -- Doc'd Python 3.9 compatibility.
Backport of e18156b6c35908f2a4026287b5225a6a4da8af1a from master.
-rw-r--r--docs/faq/install.txt4
-rw-r--r--docs/releases/2.2.17.txt7
-rw-r--r--docs/releases/2.2.txt6
-rw-r--r--docs/releases/3.0.11.txt7
-rw-r--r--docs/releases/3.0.txt4
-rw-r--r--docs/releases/index.txt2
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
8 files changed, 25 insertions, 8 deletions
diff --git a/docs/faq/install.txt b/docs/faq/install.txt
index fc8f2ec7dc..972fb73cd9 100644
--- a/docs/faq/install.txt
+++ b/docs/faq/install.txt
@@ -53,8 +53,8 @@ Django version Python versions
1.11 2.7, 3.4, 3.5, 3.6, 3.7 (added in 1.11.17)
2.0 3.4, 3.5, 3.6, 3.7
2.1 3.5, 3.6, 3.7
-2.2 3.5, 3.6, 3.7, 3.8 (added in 2.2.8)
-3.0 3.6, 3.7, 3.8
+2.2 3.5, 3.6, 3.7, 3.8 (added in 2.2.8), 3.9 (added in 2.2.17)
+3.0 3.6, 3.7, 3.8, 3.9 (added in 3.0.11)
============== ===============
For each version of Python, only the latest micro release (A.B.C) is officially
diff --git a/docs/releases/2.2.17.txt b/docs/releases/2.2.17.txt
new file mode 100644
index 0000000000..d574de6574
--- /dev/null
+++ b/docs/releases/2.2.17.txt
@@ -0,0 +1,7 @@
+===========================
+Django 2.2.17 release notes
+===========================
+
+*Expected November 2, 2020*
+
+Django 2.2.17 adds compatibility with Python 3.9.
diff --git a/docs/releases/2.2.txt b/docs/releases/2.2.txt
index d6c9c19fc6..7f9822c8cb 100644
--- a/docs/releases/2.2.txt
+++ b/docs/releases/2.2.txt
@@ -23,9 +23,9 @@ end in April 2020.
Python compatibility
====================
-Django 2.2 supports Python 3.5, 3.6, 3.7, and 3.8 (as of 2.2.8). We
-**highly recommend** and only officially support the latest release of each
-series.
+Django 2.2 supports Python 3.5, 3.6, 3.7, 3.8 (as of 2.2.8), and 3.9 (as of
+2.2.17). We **highly recommend** and only officially support the latest release
+of each series.
.. _whats-new-2.2:
diff --git a/docs/releases/3.0.11.txt b/docs/releases/3.0.11.txt
new file mode 100644
index 0000000000..a5009feb51
--- /dev/null
+++ b/docs/releases/3.0.11.txt
@@ -0,0 +1,7 @@
+===========================
+Django 3.0.11 release notes
+===========================
+
+*Expected November 2, 2020*
+
+Django 3.0.11 adds compatibility with Python 3.9.
diff --git a/docs/releases/3.0.txt b/docs/releases/3.0.txt
index 284782d80c..1c39980a91 100644
--- a/docs/releases/3.0.txt
+++ b/docs/releases/3.0.txt
@@ -19,8 +19,8 @@ project.
Python compatibility
====================
-Django 3.0 supports Python 3.6, 3.7, and 3.8. We **highly recommend** and only
-officially support the latest release of each series.
+Django 3.0 supports Python 3.6, 3.7, 3.8, and 3.9 (as of 3.0.11). We **highly
+recommend** and only officially support the latest release of each series.
The Django 2.2.x series is the last to support Python 3.5.
diff --git a/docs/releases/index.txt b/docs/releases/index.txt
index 4b2f3af8ba..b08af9fa51 100644
--- a/docs/releases/index.txt
+++ b/docs/releases/index.txt
@@ -25,6 +25,7 @@ versions of the documentation contain the release notes for any later releases.
.. toctree::
:maxdepth: 1
+ 3.0.11
3.0.10
3.0.9
3.0.8
@@ -42,6 +43,7 @@ versions of the documentation contain the release notes for any later releases.
.. toctree::
:maxdepth: 1
+ 2.2.17
2.2.16
2.2.15
2.2.14
diff --git a/setup.py b/setup.py
index eb133926ba..2c6170fe5b 100644
--- a/setup.py
+++ b/setup.py
@@ -101,6 +101,7 @@ setup(
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: 3 :: Only',
'Topic :: Internet :: WWW/HTTP',
'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
diff --git a/tox.ini b/tox.ini
index 9e0bdf7acc..15617d39c5 100644
--- a/tox.ini
+++ b/tox.ini
@@ -21,7 +21,7 @@ passenv = DJANGO_SETTINGS_MODULE PYTHONPATH HOME DISPLAY
setenv =
PYTHONDONTWRITEBYTECODE=1
deps =
- py{3,36,37,38}: -rtests/requirements/py3.txt
+ py{3,36,37,38,39}: -rtests/requirements/py3.txt
postgres: -rtests/requirements/postgres.txt
mysql: -rtests/requirements/mysql.txt
oracle: -rtests/requirements/oracle.txt