summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAsif Saifuddin Auvi <auvipy@gmail.com>2018-11-14 18:44:52 +0100
committerTim Graham <timograham@gmail.com>2018-11-17 15:35:08 -0500
commitc11a7b4907e58447daab4632a50f5e72d838715e (patch)
tree77d32a6e94c964deaa58aefa74e8d4c9c56619bf
parent8deb0a8efd948855310c45064b109090596510e4 (diff)
downloaddjango-c11a7b4907e58447daab4632a50f5e72d838715e.tar.gz
[1.11.x] Refs #28814 -- Documented Python 3.7 compatibility.
Backport of 2f7cd7f8ecb01d30c1dfdaefa1c1714db76d2553 from master
-rw-r--r--docs/faq/install.txt4
-rw-r--r--docs/releases/1.11.17.txt3
-rw-r--r--docs/releases/1.11.txt6
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
5 files changed, 9 insertions, 7 deletions
diff --git a/docs/faq/install.txt b/docs/faq/install.txt
index 12482362d8..e556d3550c 100644
--- a/docs/faq/install.txt
+++ b/docs/faq/install.txt
@@ -48,8 +48,8 @@ Django version Python versions
============== ===============
1.8 2.7, 3.2 (until the end of 2016), 3.3, 3.4, 3.5
1.9, 1.10 2.7, 3.4, 3.5
-1.11 2.7, 3.4, 3.5, 3.6
-2.0 3.4, 3.5, 3.6
+1.11 2.7, 3.4, 3.5, 3.6, 3.7 (added in 1.11.17)
+2.0 3.4, 3.5, 3.6, 3.7
2.1 3.5, 3.6, 3.7
============== ===============
diff --git a/docs/releases/1.11.17.txt b/docs/releases/1.11.17.txt
index db201d0b9a..26bdfb0de0 100644
--- a/docs/releases/1.11.17.txt
+++ b/docs/releases/1.11.17.txt
@@ -4,7 +4,8 @@ Django 1.11.17 release notes
*Release date TBD*
-Django 1.11.17 fixes several bugs in 1.11.16.
+Django 1.11.17 fixes several bugs in 1.11.16 and adds compatibility with
+Python 3.7.
Bugfixes
========
diff --git a/docs/releases/1.11.txt b/docs/releases/1.11.txt
index 4debdb4842..377c402eb7 100644
--- a/docs/releases/1.11.txt
+++ b/docs/releases/1.11.txt
@@ -22,9 +22,9 @@ for the previous LTS, Django 1.8, will end in April 2018.
Python compatibility
====================
-Django 1.11 requires Python 2.7, 3.4, 3.5, or 3.6. Django 1.11 is the first
-release to support Python 3.6. We **highly recommend** and only officially
-support the latest release of each series.
+Django 1.11 requires Python 2.7, 3.4, 3.5, 3.6, or 3.7 (as of 1.11.17). We
+**highly recommend** and only officially support the latest release of each
+series.
The Django 1.11.x series is the last to support Python 2. The next major
release, Django 2.0, will only support Python 3.4+.
diff --git a/setup.py b/setup.py
index db7d079549..e3cf07ee39 100644
--- a/setup.py
+++ b/setup.py
@@ -67,6 +67,7 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Topic :: Internet :: WWW/HTTP',
'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
'Topic :: Internet :: WWW/HTTP :: WSGI',
diff --git a/tox.ini b/tox.ini
index e9892a75a4..af43e94382 100644
--- a/tox.ini
+++ b/tox.ini
@@ -25,7 +25,7 @@ setenv =
PYTHONDONTWRITEBYTECODE=1
deps =
py{2,27}: -rtests/requirements/py2.txt
- py{3,34,35,36}: -rtests/requirements/py3.txt
+ py{3,34,35,36,37}: -rtests/requirements/py3.txt
postgres: -rtests/requirements/postgres.txt
mysql: -rtests/requirements/mysql.txt
oracle: -rtests/requirements/oracle.txt