summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini9
1 files changed, 8 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index e665374..1920c59 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27,py35,py36,py37,py38,pep8py2,pep8py3,doc
+envlist = py27,py35,py36,py37,py38,black,pep8py2,pep8py3,doc
skip_missing_interpreters = true
[testenv]
@@ -14,6 +14,13 @@ commands =
# lxml FTBFS because Python sets -Wimplicit-int
deps =
+[testenv:black]
+commands = black --check --verbose \
+ {toxinidir}/setup.py \
+ {toxinidir}/tests.py \
+ {toxinidir}/defusedxml/
+deps = black
+
[testenv:pep8py2]
basepython = python2.7
deps =