summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>2021-08-23 08:52:00 -0400
committerGitHub <noreply@github.com>2021-08-23 08:52:00 -0400
commit8e671be7a1f9738719617e2da08c26d9da2d44b8 (patch)
treee6446ee2e63cb3a0d6e11bffcf0c8194f326b618
parentf7ba53cb5050c465338baa127abc0243663cf217 (diff)
downloadcryptography-8e671be7a1f9738719617e2da08c26d9da2d44b8.tar.gz
Bump pyo3 from 0.14.2 to 0.14.3 in /src/rust (#6216)
Bumps [pyo3](https://github.com/pyo3/pyo3) from 0.14.2 to 0.14.3. - [Release notes](https://github.com/pyo3/pyo3/releases) - [Changelog](https://github.com/PyO3/pyo3/blob/main/CHANGELOG.md) - [Commits](https://github.com/pyo3/pyo3/compare/v0.14.2...v0.14.3) --- updated-dependencies: - dependency-name: pyo3 dependency-type: direct:production update-type: version-update:semver-patch ... Signed-off-by: dependabot[bot] <support@github.com> Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
-rw-r--r--src/rust/Cargo.lock16
-rw-r--r--src/rust/Cargo.toml2
2 files changed, 9 insertions, 9 deletions
diff --git a/src/rust/Cargo.lock b/src/rust/Cargo.lock
index 354147199..5cd467f25 100644
--- a/src/rust/Cargo.lock
+++ b/src/rust/Cargo.lock
@@ -279,9 +279,9 @@ dependencies = [
[[package]]
name = "pyo3"
-version = "0.14.2"
+version = "0.14.3"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "af205762ba65eec9f27a2fa1a57a40644e8e3368784b8c8b2f2de48f6e8ddd96"
+checksum = "4ce0e80b2b35e9697353a25b0e4fa5374e38c451da2f86f0cd83c40e7f1d5191"
dependencies = [
"cfg-if",
"indoc",
@@ -295,18 +295,18 @@ dependencies = [
[[package]]
name = "pyo3-build-config"
-version = "0.14.2"
+version = "0.14.3"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "755944027ce803c7238e59c5a18e59c1d0a4553db50b23e9ba209a568353028d"
+checksum = "96007b58c38d68ae449ea4d82fbc390faf5f1f2c80c76a6e3d51385bceb56741"
dependencies = [
"once_cell",
]
[[package]]
name = "pyo3-macros"
-version = "0.14.2"
+version = "0.14.3"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "cd31b36bccfd902c78804bd96c28ea93eac6fa0ca311f9d21ef2230b6665b29a"
+checksum = "326afb5c23f9789d0a367c37d58275c4d0e97ca74f05b9a25c0d66c6395c1c7b"
dependencies = [
"pyo3-macros-backend",
"quote",
@@ -315,9 +315,9 @@ dependencies = [
[[package]]
name = "pyo3-macros-backend"
-version = "0.14.2"
+version = "0.14.3"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "c21c59ba36db9c823e931c662766b0dd01a030b1d96585b67d8857a96a56b972"
+checksum = "7e38169a08f98219bba484d19100811a1646d4962706b75d60766d21dce64f9c"
dependencies = [
"proc-macro2",
"pyo3-build-config",
diff --git a/src/rust/Cargo.toml b/src/rust/Cargo.toml
index 45a853d83..d8c1f2c35 100644
--- a/src/rust/Cargo.toml
+++ b/src/rust/Cargo.toml
@@ -7,7 +7,7 @@ publish = false
[dependencies]
lazy_static = "1"
-pyo3 = { version = "0.14.2" }
+pyo3 = { version = "0.14.3" }
asn1 = { version = "0.6", default-features = false, features = ["derive"] }
pem = "0.8"
chrono = { version = "0.4", default-features = false, features = ["alloc"] }