summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2014-12-18 07:42:27 -0600
committerPaul Kehrer <paul.l.kehrer@gmail.com>2015-01-15 12:41:00 -0600
commit7ab5c39d859cb39b23b196f88e7b8881357b1262 (patch)
tree33679e27a8ac5a7098346970a471c66dc1fab7f9
parent9a4f1a0f6c89e3e56b955e5acc6c0001e418443d (diff)
downloadcryptography-7ab5c39d859cb39b23b196f88e7b8881357b1262.tar.gz
make enum34 installation conditional on python < 3.4
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ead5ec4f9..32a87ba3c 100644
--- a/setup.py
+++ b/setup.py
@@ -36,12 +36,14 @@ VECTORS_DEPENDENCY = "cryptography_vectors=={0}".format(about['__version__'])
requirements = [
CFFI_DEPENDENCY,
- "enum34",
"pyasn1",
SIX_DEPENDENCY,
SETUPTOOLS_DEPENDENCY
]
+if sys.version_info < (3, 4):
+ requirements.append("enum34")
+
# If you add a new dep here you probably need to add it in the tox.ini as well
test_requirements = [
"pytest",