summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šedivý <6774676+eumiro@users.noreply.github.com>2020-12-28 15:52:44 +0100
committerMiroslav Šedivý <6774676+eumiro@users.noreply.github.com>2020-12-28 15:52:44 +0100
commitdacbee6483068c81e53a2af5c04a1563dd77883a (patch)
treef9b4b7d1f247c52e5bfc458e1902ea3a289563a5
parent4697e7996ad87e16653c2695e6bb247d72143b0d (diff)
downloadcroniter-dacbee6483068c81e53a2af5c04a1563dd77883a.tar.gz
Add Python 3.8 and 3.9 support
-rw-r--r--.travis.yml1
-rw-r--r--docs/CHANGES.rst3
-rw-r--r--setup.py2
-rw-r--r--tox.ini6
4 files changed, 8 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index 89e5947..7f3d1a8 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -8,6 +8,7 @@ python:
- 3.6
- 3.7
- 3.8
+ - 3.9
install:
- pip install -r requirements/test.txt
script:
diff --git a/docs/CHANGES.rst b/docs/CHANGES.rst
index 71472e8..31d90b6 100644
--- a/docs/CHANGES.rst
+++ b/docs/CHANGES.rst
@@ -4,7 +4,8 @@ Changelog
0.3.37 (unreleased)
-------------------
-- Nothing changed yet.
+- Added Python 3.8 and 3.9 support
+ [eumiro]
0.3.36 (2020-11-02)
diff --git a/setup.py b/setup.py
index bd5bf35..0dad4ae 100644
--- a/setup.py
+++ b/setup.py
@@ -51,6 +51,8 @@ setup(
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
"Topic :: Software Development :: Libraries :: Python Modules"],
packages=find_packages('src', exclude=['tests*', '*.tests*']),
package_dir={'': 'src'},
diff --git a/tox.ini b/tox.ini
index a413d2d..f0a7474 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
[tox]
minversion = 2.3
envlist =
- {py26,py27,py34,py35,py36,py37}-std
+ {py26,py27,py34,py35,py36,py37,py38,py39}-std
py27-coverage
skipsdist = true
@@ -14,8 +14,8 @@ setenv =
COVERAGE_FILE={envdir}/coverage_report
changedir = src
commands =
- {py26,py27,py34,py35,py36,py37}-std: py.test -v .
- {py27,py34,py35,py36,py37}-std: flake8 croniter/croniter.py
+ {py26,py27,py34,py35,py36,py37,py38,py39}-std: py.test -v .
+ {py27,py34,py35,py36,py37,py38,py39}-std: flake8 croniter/croniter.py
py27-coverage: coverage erase
py27-coverage: sh -c 'cd .. && coverage run $(which py.test) -v src'
py27-coverage: coverage report