summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml9
1 files changed, 3 insertions, 6 deletions
diff --git a/pyproject.toml b/pyproject.toml
index d84017a..1dc3927 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -36,8 +36,7 @@ packages = [
include = ['AUTHORS', 'LICENSE']
[tool.poetry.dependencies]
-# TODO: Restrict to >=3.7
-python = ">=3.6,<4.0.0"
+python = ">=3.7,<4.0.0"
docutils = "*"
[tool.poetry.dev-dependencies]
@@ -49,10 +48,8 @@ textile = "*"
pytest = "*"
pytest-cov = "*"
isort = "*"
-flake8 = "*"
-flynt = "*"
+pylint = "*"
autopep8 = "*"
-pyupgrade = "*"
darker = "*"
[tool.poetry.scripts]
@@ -79,7 +76,7 @@ check = false
stdout = false
isort = true
lint = [
- "flake8",
+ "pylint",
]
log_level = "INFO"