summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 669086e..866c16a 100644
--- a/Makefile
+++ b/Makefile
@@ -29,14 +29,15 @@ install: check-poetry ## install python-creole via poetry
poetry install
lint: ## Run code formatters and linter
+ poetry run flynt --fail-on-change --line_length=119 creole
# poetry run isort --check-only --recursive creole
# poetry run black --line-length=119 --check creole
- poetry run flake8 creole
+# poetry run flake8 creole
fix-code-style: ## Fix code formatting
-# poetry run flynt --line_length=119 creole
+ poetry run flynt --line_length=119 creole
# poetry run isort --apply --recursive creole
- poetry run autopep8 --ignore-local-config --max-line-length=${MAX_LINE_LENGTH} --aggressive --aggressive --in-place --recursive creole
+# poetry run autopep8 --ignore-local-config --max-line-length=${MAX_LINE_LENGTH} --aggressive --aggressive --in-place --recursive creole
tox-listenvs: check-poetry ## List all tox test environments
poetry run tox --listenvs