summaryrefslogtreecommitdiff
path: root/creole
diff options
context:
space:
mode:
authorJensDiemer <git@jensdiemer.de>2015-08-15 22:28:25 +0200
committerJensDiemer <git@jensdiemer.de>2015-08-15 22:28:25 +0200
commit920e02c33d9ff53ccbb315b3b0bd9b1a61b38caf (patch)
tree636000f73183ede7ff2a1846d091733ec425ffc2 /creole
parente26736417250de16072d3c737a1c5ef984cb7d37 (diff)
downloadcreole-920e02c33d9ff53ccbb315b3b0bd9b1a61b38caf.tar.gz
Add LICENSE in MANIFEST.in to bugfix setup.py run:v1.3.1
e.g.: https://travis-ci.org/jedie/PyLucid/builds/75760087#L407-L412 + update setup publish code from: https://github.com/jedie/python-code-snippets/blob/master/CodeSnippets/setup_publish.py
Diffstat (limited to 'creole')
-rw-r--r--creole/__init__.py14
1 files changed, 5 insertions, 9 deletions
diff --git a/creole/__init__.py b/creole/__init__.py
index 37487c9..6ca2008 100644
--- a/creole/__init__.py
+++ b/creole/__init__.py
@@ -14,16 +14,12 @@
:PyPi:
http://pypi.python.org/pypi/python-creole/
- :copyleft: 2008-2014 by python-creole team, see AUTHORS for more details.
+ :copyleft: 2008-2015 by python-creole team, see AUTHORS for more details.
:license: GNU GPL v3 or above, see LICENSE for more details.
"""
from __future__ import division, absolute_import, print_function, unicode_literals
-__version__ = (1, 3, 0)
-__api__ = (1, 0) # Creole 1.0 spec - http://wikicreole.org/
-
-
import warnings
from creole.emitter.creol2html_emitter import HtmlEmitter
@@ -35,11 +31,11 @@ from creole.parser.html_parser import HtmlParser
from creole.py3compat import TEXT_TYPE
-# TODO: Add git date to __version__
-
+__version__ = "1.3.1"
+__api__ = "1.0" # Creole 1.0 spec - http://wikicreole.org/
-VERSION_STRING = '.'.join(str(part) for part in __version__)
-API_STRING = '.'.join(str(integer) for integer in __api__)
+VERSION_STRING = __version__ # remove in future
+API_STRING = __api__ # remove in future
def creole2html(markup_string, debug=False,