summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJensDiemer <git@jensdiemer.de>2015-06-02 09:43:28 +0200
committerJensDiemer <git@jensdiemer.de>2015-06-02 09:43:28 +0200
commit06dd7f47bb983357dbd933ab96ee665685017b14 (patch)
tree7118bf5f23de5d40b0fdb60b66fcedc6b0a85a8c
parente8c0c15bd21724c612ef58ee039a81d70ece2848 (diff)
downloadcreole-06dd7f47bb983357dbd933ab96ee665685017b14.tar.gz
+coveralls.io +landscape.io
-rw-r--r--.travis.yml15
-rw-r--r--README.creole8
2 files changed, 13 insertions, 10 deletions
diff --git a/.travis.yml b/.travis.yml
index 80dcf52..2bc44f8 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,4 +1,5 @@
language: python
+
python:
- "2.6"
- "2.7"
@@ -6,13 +7,15 @@ python:
- "3.4"
- "pypy"
- "pypy3"
+
install:
- - pip install --verbose "textile>=2.1.8" docutils pygments
-# command to run tests
+ - pip install --verbose "textile>=2.1.8" docutils pygments coveralls
+
script:
- - ./setup.py test
-branches:
- only:
- - master
+ - coverage run ./setup.py test
+
+after_success:
+ coveralls
+
notifications:
irc: "irc.freenode.org#pylucid"
diff --git a/README.creole b/README.creole
index 6076795..b0838f5 100644
--- a/README.creole
+++ b/README.creole
@@ -19,6 +19,10 @@ Existing converters:
The creole2html part based on the creole markup parser and emitter from the MoinMoin project by Radomir Dopieralski and Thomas Waldmann.
+| {{https://travis-ci.org/jedie/python-creole.svg|Build Status on travis-ci.org}} | [[https://travis-ci.org/jedie/python-creole/|travis-ci.org/jedie/python-creole]] |
+| {{https://coveralls.io/repos/jedie/python-creole/badge.svg|Coverage Status on coveralls.io}} | [[https://coveralls.io/r/jedie/python-creole|coveralls.io/r/jedie/python-creole]] |
+| {{https://landscape.io/github/jedie/python-creole/master/landscape.svg|Status on landscape.io}} | [[https://landscape.io/github/jedie/python-creole/master|landscape.io/github/jedie/python-creole/master]] |
+
= install =
@@ -148,10 +152,6 @@ Contributers should take a look at this page:
== unittests ==
-[[https://travis-ci.org/jedie/python-creole|python-creole @ Travis CI]]: {{https://secure.travis-ci.org/jedie/python-creole.png?branch=master|Build Status on travis-ci.org}}
-* https://travis-ci.org/jedie/python-creole
-
-
=== run unittests ===
From source package, use setup.py to run unittests (Works without install python-creole, needs setuptools):