summaryrefslogtreecommitdiff
path: root/.editorconfig
diff options
context:
space:
mode:
authorJensDiemer <git@jensdiemer.de>2020-01-18 18:00:01 +0100
committerJensDiemer <git@jensdiemer.de>2020-01-18 18:00:01 +0100
commit6daa915fe6b236c1a8b77aecc3c7c76c838b2f56 (patch)
tree0662f1b5361b145090002de97b750f6c5d53bf0b /.editorconfig
parentc33fac617ada1a97b4f60a471f5dcf32e992fe75 (diff)
downloadcreole-6daa915fe6b236c1a8b77aecc3c7c76c838b2f56.tar.gz
modernize project
* use poetry * add a Makefile * add github actions * nose -> pytest
Diffstat (limited to '.editorconfig')
-rw-r--r--.editorconfig24
1 files changed, 24 insertions, 0 deletions
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 0000000..40bd47a
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,24 @@
+# see http://editorconfig.org
+root = true
+
+[*]
+indent_style = space
+indent_size = 4
+end_of_line = lf
+charset = utf-8
+trim_trailing_whitespace = true
+insert_final_newline = true
+
+[*.{html,css,js}]
+insert_final_newline = false
+
+[*.py]
+line_length = 119
+
+[{Makefile,**.mk}]
+indent_style = tab
+insert_final_newline = false
+
+[*.{yml}]
+indent_style = space
+indent_size = 2