summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configshell/__init__.py6
-rwxr-xr-xsetup.py30
2 files changed, 10 insertions, 26 deletions
diff --git a/configshell/__init__.py b/configshell/__init__.py
index a7cbeea..e6649b7 100644
--- a/configshell/__init__.py
+++ b/configshell/__init__.py
@@ -20,9 +20,3 @@ from console import Console
from shell import ConfigShell
from node import ConfigNode, ExecutionError
from prefs import Prefs
-
-__version__ = 'GIT_VERSION'
-__author__ = "Jerome Martin <jxm@risingtidesystems.com>"
-__url__ = "http://www.risingtidesystems.com"
-__description__ = "A framework to implement simple but nice CLIs."
-__license__ = __doc__
diff --git a/setup.py b/setup.py
index 366512d..2048bcb 100755
--- a/setup.py
+++ b/setup.py
@@ -16,25 +16,15 @@ License for the specific language governing permissions and limitations
under the License.
'''
-import re
from distutils.core import setup
-import configshell
-PKG = configshell
-VERSION = str(PKG.__version__)
-(AUTHOR, EMAIL) = re.match('^(.*?)\s*<(.*)>$', PKG.__author__).groups()
-URL = PKG.__url__
-LICENSE = PKG.__license__
-SCRIPTS = []
-DESCRIPTION = PKG.__description__
-
-setup(name=PKG.__name__,
- description=DESCRIPTION,
- version=VERSION,
- author=AUTHOR,
- author_email=EMAIL,
- license=LICENSE,
- url=URL,
- scripts=SCRIPTS,
- packages=[PKG.__name__],
- package_data = {'':[]})
+setup(
+ name = 'configshell-fb',
+ version = 'v1.1.fb8',
+ description = 'A framework to implement simple but nice CLIs.',
+ license = 'Apache 2.0',
+ maintainer = 'Andy Grover',
+ maintainer_email = 'agrover@redhat.com',
+ url = 'http://github.com/agrover/configshell-fb',
+ packages = ['configshell'],
+ )