summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Dewender <github@JonnyJD.net>2013-10-19 14:05:26 +0200
committerJohannes Dewender <github@JonnyJD.net>2013-10-20 11:21:13 +0200
commita630d0bc19bcc076b257efa52ac6407cec281137 (patch)
tree0c83b6e2830bc5fc1b3e75dc3b56d6db964e5bdb
parent095e8eec3e4300bef7b65981ec0674a6dc3dd779 (diff)
downloadconfigshell-fb-a630d0bc19bcc076b257efa52ac6407cec281137.tar.gz
debian: update packaging to use dh_python
Signed-off-by: Johannes Dewender <github@JonnyJD.net>
-rw-r--r--debian/control9
-rw-r--r--debian/python-configshell-fb.dirs1
-rw-r--r--debian/python-configshell-fb.docs4
-rw-r--r--debian/python-configshell-fb.install1
-rwxr-xr-xdebian/python-configshell-fb.postinst17
-rwxr-xr-xdebian/python-configshell-fb.preinst3
-rwxr-xr-xdebian/python-configshell-fb.prerm8
-rw-r--r--debian/pyversions1
-rwxr-xr-xdebian/rules57
9 files changed, 17 insertions, 84 deletions
diff --git a/debian/control b/debian/control
index 81c5cb8..be4314d 100644
--- a/debian/control
+++ b/debian/control
@@ -2,15 +2,16 @@ Source: configshell-fb
Section: python
Priority: optional
Maintainer: Andy Grover <grover@groveronline.com>
-Build-Depends: debhelper(>= 7.0.1), python (>= 2.6), python-setuptools, python-epydoc, python-pyparsing
-Standards-Version: 3.8.1
+Build-Depends: debhelper(>= 8), python (>=2.6.6-3~), python-setuptools, python-epydoc, python-pyparsing
+Standards-Version: 3.9.4
+X-Python-Version: >= 2.6
Package: python-configshell-fb
Architecture: all
-Depends: python (>= 2.6), python-pyparsing, python-urwid (>=0.9.9)
+Depends: ${python:Depends}, ${misc:Depends}, python-pyparsing, python-urwid (>=0.9.9)
Suggests: configshell-fb-doc
Conflicts: configshell
-Provides: configshell
+Provides: ${python:Provides}
Description: Framework to create CLI interfaces.
.
This package contains the configshell library (free branch).
diff --git a/debian/python-configshell-fb.dirs b/debian/python-configshell-fb.dirs
deleted file mode 100644
index 145429c..0000000
--- a/debian/python-configshell-fb.dirs
+++ /dev/null
@@ -1 +0,0 @@
-usr/share/python-support
diff --git a/debian/python-configshell-fb.docs b/debian/python-configshell-fb.docs
deleted file mode 100644
index 5686710..0000000
--- a/debian/python-configshell-fb.docs
+++ /dev/null
@@ -1,4 +0,0 @@
-README.md
-COPYING
-doc/html
-examples/myshell
diff --git a/debian/python-configshell-fb.install b/debian/python-configshell-fb.install
deleted file mode 100644
index 69bb674..0000000
--- a/debian/python-configshell-fb.install
+++ /dev/null
@@ -1 +0,0 @@
-lib/configshell usr/share/python-support
diff --git a/debian/python-configshell-fb.postinst b/debian/python-configshell-fb.postinst
deleted file mode 100755
index b56990a..0000000
--- a/debian/python-configshell-fb.postinst
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/bin/sh
-for lib in lib lib64; do
- for python in python2.6; do
- if [ -e /usr/${lib}/${python} ]; then
- if [ ! -e /usr/${lib}/${python}/configshell ]; then
- mkdir /usr/${lib}/${python}/configshell
- for source in /usr/share/python-support/configshell/configshell/*.py; do
- ln -sf ${source} /usr/${lib}/${python}/configshell/
- done
- python_path=$(which ${python} 2>/dev/null)
- if [ ! -z $python_path ]; then
- ${python} -c "import compileall; compileall.compile_dir('/usr/${lib}/${python}/configshell', force=1)"
- fi
- fi
- fi
- done
-done
diff --git a/debian/python-configshell-fb.preinst b/debian/python-configshell-fb.preinst
deleted file mode 100755
index b96bf44..0000000
--- a/debian/python-configshell-fb.preinst
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-rm -f /usr/share/python-support/configshell/configshell/*.pyc
-rm -f /usr/share/python-support/configshell/configshell/*.pyo
diff --git a/debian/python-configshell-fb.prerm b/debian/python-configshell-fb.prerm
deleted file mode 100755
index 866a5c2..0000000
--- a/debian/python-configshell-fb.prerm
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-for lib in lib lib64; do
- for python in python2.6; do
- if [ -e /usr/${lib}/${python}/configshell ]; then
- rm -rf /usr/${lib}/${python}/configshell
- fi
- done
-done
diff --git a/debian/pyversions b/debian/pyversions
deleted file mode 100644
index 0c043f1..0000000
--- a/debian/pyversions
+++ /dev/null
@@ -1 +0,0 @@
-2.6-
diff --git a/debian/rules b/debian/rules
index c349318..1f737a1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,57 +1,24 @@
#!/usr/bin/make -f
-build_dir = build
-install_dir = debian/tmp
-setup = /usr/bin/python ./setup.py --quiet
+build_dir = build
pkgname = configshell-fb
name = configshell
-export PYTHONPATH = $$PYTHONPATH:./$(install_dir)/lib/configshell/
+#export DH_VERBOSE=1
-binary: binary-indep
+# prevent internet access to use PyPi
+export http_proxy = http://127.0.0.1:9
-binary-arch:
+%:
+ dh $@ --with python2
-binary-indep: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs
- dh_installdocs
- dh_installman
- dh_install --list-missing --sourcedir $(install_dir)
- dh_fixperms
- dh_compress -X.py
- dh_installdeb
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-install: build
- dh_testdir
- dh_testroot
- dh_installdirs
-
-build: build-stamp
-build-stamp:
- dh_testdir
- mkdir -p $(install_dir)/lib/configshell
- $(setup) build --build-base $(build_dir) install --no-compile --install-purelib $(install_dir)/lib/configshell --install-scripts $(install_dir)/bin
- echo "2.6" > $(install_dir)/lib/configshell/.version
+override_dh_installdocs:
mkdir -p $(build_dir) doc/
cd $(build_dir); epydoc --no-sourcecode --html -n $(pkgname) \
--exclude configobj ../$(name)/*.py
- cp -r $(build_dir)/html doc/
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
- $(setup) clean
- find . -name "*.pyc" | xargs rm -f
- find . -name "*.pyo" | xargs rm -f
- rm -rf $(build_dir) $(install_dir)
- dh_clean
-
-.PHONY: binary binary-indep install build clean
+ dh_installdocs $(build_dir)/html
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -rf build
+ rm -rf *.egg-info