summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Dewender <github@JonnyJD.net>2013-10-16 15:10:14 +0200
committerJohannes Dewender <github@JonnyJD.net>2013-10-18 19:50:31 +0200
commit9df1c5014be0d00cc6e5e15a52da2852d7a0895a (patch)
tree4448c0a5a2c2e112331d4afdc593a4e22f651486
parent9a2f993add2c7cc8f1ecc3d3aea06486a8d5d233 (diff)
downloadconfigshell-fb-9df1c5014be0d00cc6e5e15a52da2852d7a0895a.tar.gz
rename debian package to configshell-fb
This is an alternative to the original configshell. Signed-off-by: Johannes Dewender <github@JonnyJD.net>
-rw-r--r--Makefile37
-rw-r--r--debian/control13
-rw-r--r--debian/copyright4
-rw-r--r--debian/python-configshell-fb.dirs (renamed from debian/python-configshell.dirs)0
-rw-r--r--debian/python-configshell-fb.docs (renamed from debian/python-configshell.docs)0
-rw-r--r--debian/python-configshell-fb.install (renamed from debian/python-configshell.install)0
-rwxr-xr-xdebian/python-configshell-fb.postinst (renamed from debian/python-configshell.postinst)0
-rwxr-xr-xdebian/python-configshell-fb.preinst (renamed from debian/python-configshell.preinst)0
-rwxr-xr-xdebian/python-configshell-fb.prerm (renamed from debian/python-configshell.prerm)0
-rwxr-xr-xdebian/rules2
10 files changed, 29 insertions, 27 deletions
diff --git a/Makefile b/Makefile
index dff83ce..7f098b9 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,4 @@
+PKGNAME = configshell-fb
NAME = configshell
GIT_BRANCH = $$(git branch | grep \* | tr -d \*)
VERSION = $$(basename $$(git describe --tags | tr - . | sed 's/^v//'))
@@ -21,11 +22,11 @@ clean:
@rm -fv dpkg-buildpackage.log dpkg-buildpackage.version
@rm -frv *.rpm
@rm -fv debian/files debian/*.log debian/*.substvars
- @rm -frv debian/${NAME}-doc/ debian/python2.5-${NAME}/
- @rm -frv debian/python2.6-${NAME}/ debian/python-${NAME}/
+ @rm -frv debian/${PKGNAME}-doc/ debian/python2.5-${PKGNAME}/
+ @rm -frv debian/python2.6-${PKGNAME}/ debian/python-${PKGNAME}/
@rm -frv results
@rm -fv rpm/*.spec *.spec rpm/sed* sed*
- @rm -frv ${NAME}-*
+ @rm -frv ${PKGNAME}-*
@echo "Finished cleanup."
cleanall: clean
@@ -35,16 +36,16 @@ release: build/release-stamp
build/release-stamp:
@mkdir -p build
@echo "Exporting the repository files..."
- @git archive ${GIT_BRANCH} --prefix ${NAME}-${VERSION}/ \
+ @git archive ${GIT_BRANCH} --prefix ${PKGNAME}-${VERSION}/ \
| (cd build; tar xfp -)
@echo "Cleaning up the target tree..."
- @rm -f build/${NAME}-${VERSION}/Makefile
- @rm -f build/${NAME}-${VERSION}/.gitignore
+ @rm -f build/${PKGNAME}-${VERSION}/Makefile
+ @rm -f build/${PKGNAME}-${VERSION}/.gitignore
@echo "Fixing version string..."
@sed -i "s/__version__ = .*/__version__ = '${VERSION}'/g" \
- build/${NAME}-${VERSION}/${NAME}/__init__.py
+ build/${PKGNAME}-${VERSION}/${NAME}/__init__.py
@echo "Generating rpm specfile from template..."
- @cd build/${NAME}-${VERSION}; \
+ @cd build/${PKGNAME}-${VERSION}; \
for spectmpl in rpm/*.spec.tmpl; do \
sed -i "s/Version:\( *\).*/Version:\1${VERSION}/g" $${spectmpl}; \
mv $${spectmpl} $$(basename $${spectmpl} .tmpl); \
@@ -59,7 +60,7 @@ build/release-stamp:
hash=$$(git show HEAD --format="format:%H" -s); \
echo '* '"$${date} $${author} $${version}-1"; \
echo " - Generated from git commit $${hash}."; \
- ) >> $$(ls build/${NAME}-${VERSION}/*.spec)
+ ) >> $$(ls build/${PKGNAME}-${VERSION}/*.spec)
@echo "Generating debian changelog..."
@( \
version=${VERSION}; \
@@ -71,30 +72,30 @@ build/release-stamp:
date=$$(echo $${date} \
| awk '{print $$1, "'"$${day}"'", $$3, $$4, $$5, $$6}'); \
hash=$$(git show HEAD --format="format:%H" -s); \
- echo "${NAME} ($${version}) unstable; urgency=low"; \
+ echo "${PKGNAME} ($${version}) unstable; urgency=low"; \
echo; \
echo " * Generated from git commit $${hash}."; \
echo; \
echo " -- $${author} $${date}"; \
echo; \
- ) > build/${NAME}-${VERSION}/debian/changelog
- @find build/${NAME}-${VERSION}/ -exec \
+ ) > build/${PKGNAME}-${VERSION}/debian/changelog
+ @find build/${PKGNAME}-${VERSION}/ -exec \
touch -t $$(date -d @$$(git show -s --format="format:%at") \
+"%Y%m%d%H%M.%S") {} \;
@mkdir -p dist
@cd build; tar -c --owner=0 --group=0 --numeric-owner \
--format=gnu -b20 --quoting-style=escape \
- -f ../dist/${NAME}-${VERSION}.tar \
- $$(find ${NAME}-${VERSION} -type f | sort)
- @gzip -6 -n dist/${NAME}-${VERSION}.tar
+ -f ../dist/${PKGNAME}-${VERSION}.tar \
+ $$(find ${PKGNAME}-${VERSION} -type f | sort)
+ @gzip -6 -n dist/${PKGNAME}-${VERSION}.tar
@echo "Generated release tarball:"
- @echo " $$(ls dist/${NAME}-${VERSION}.tar.gz)"
+ @echo " $$(ls dist/${PKGNAME}-${VERSION}.tar.gz)"
@touch build/release-stamp
deb: release build/deb-stamp
build/deb-stamp:
@echo "Building debian packages..."
- @cd build/${NAME}-${VERSION}; \
+ @cd build/${PKGNAME}-${VERSION}; \
dpkg-buildpackage -rfakeroot -us -uc
@mv build/*_${VERSION}_*.deb dist/
@echo "Generated debian packages:"
@@ -108,7 +109,7 @@ build/rpm-stamp:
@build=$$(pwd)/build/rpm; dist=$$(pwd)/dist/; rpmbuild \
--define "_topdir $${build}" --define "_sourcedir $${dist}" \
--define "_rpmdir $${build}" --define "_buildir $${build}" \
- --define "_srcrpmdir $${build}" -ba build/${NAME}-${VERSION}/*.spec
+ --define "_srcrpmdir $${build}" -ba build/${PKGNAME}-${VERSION}/*.spec
@mv build/rpm/*-${VERSION}*.src.rpm dist/
@mv build/rpm/*/*-${VERSION}*.rpm dist/
@echo "Generated rpm packages:"
diff --git a/debian/control b/debian/control
index 05bb316..6a9890d 100644
--- a/debian/control
+++ b/debian/control
@@ -1,14 +1,15 @@
-Source: configshell
+Source: configshell-fb
Section: python
Priority: optional
-Maintainer: Jerome Martin <jxm@risingtidesystems.com>
-Build-Depends: debhelper(>= 7.0.1), python2.6
+Maintainer: Andy Grover <grover@groveronline.com>
+Build-Depends: debhelper(>= 7.0.1), python (>= 2.6)|python2.6
Standards-Version: 3.8.1
-Package: python-configshell
+Package: python-configshell-fb
Architecture: all
Depends: python (>= 2.6)|python2.6, python-epydoc, python-pyparsing, python-urwid (>=0.9.9)
-Suggests: configshell-doc
+Suggests: configshell-fb-doc
+Conflicts: configshell
Description: Framework to create CLI interfaces.
.
- This package contains the configshell library.
+ This package contains the configshell library (free branch).
diff --git a/debian/copyright b/debian/copyright
index 28b41fa..f2c98df 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,6 +1,6 @@
This package was originally debianized by Jerome Martin <jxm@risingtidesystems.com>
-on Thu Sep 09 23:13:01 CET 2010. It is currently maintained by Jerome Martin
-<jxm@risingtidesystems.com>.
+on Thu Sep 09 23:13:01 CET 2010. It is currently maintained by Andy Grover
+<andy@groveronline.com>.
Upstream Author: Jerome Martin <jxm@risingtidesystems.com>
diff --git a/debian/python-configshell.dirs b/debian/python-configshell-fb.dirs
index 145429c..145429c 100644
--- a/debian/python-configshell.dirs
+++ b/debian/python-configshell-fb.dirs
diff --git a/debian/python-configshell.docs b/debian/python-configshell-fb.docs
index 5686710..5686710 100644
--- a/debian/python-configshell.docs
+++ b/debian/python-configshell-fb.docs
diff --git a/debian/python-configshell.install b/debian/python-configshell-fb.install
index 69bb674..69bb674 100644
--- a/debian/python-configshell.install
+++ b/debian/python-configshell-fb.install
diff --git a/debian/python-configshell.postinst b/debian/python-configshell-fb.postinst
index b56990a..b56990a 100755
--- a/debian/python-configshell.postinst
+++ b/debian/python-configshell-fb.postinst
diff --git a/debian/python-configshell.preinst b/debian/python-configshell-fb.preinst
index b96bf44..b96bf44 100755
--- a/debian/python-configshell.preinst
+++ b/debian/python-configshell-fb.preinst
diff --git a/debian/python-configshell.prerm b/debian/python-configshell-fb.prerm
index 866a5c2..866a5c2 100755
--- a/debian/python-configshell.prerm
+++ b/debian/python-configshell-fb.prerm
diff --git a/debian/rules b/debian/rules
index d9a49a1..7f48a20 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,7 @@
build_dir = build
install_dir = debian/tmp
setup = /usr/bin/python ./setup.py --quiet
-name = configshell
+name = configshell-fb
binary: binary-indep