summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Dewender <github@JonnyJD.net>2013-10-16 14:08:44 +0200
committerJohannes Dewender <github@JonnyJD.net>2013-10-16 14:21:39 +0200
commit926d4beade1e30b5ea93ad852f4539474a48f92d (patch)
treea8e194808e7c7ff56a77e74635cc52b051396cb0
parentdccc4edce83fc0cfbc4c6ffa867140838225a236 (diff)
downloadconfigshell-fb-926d4beade1e30b5ea93ad852f4539474a48f92d.tar.gz
fix version in package builds
Without this fix at least dpkg complains about the version not starting with a number (starting with "v"). Signed-off-by: Johannes Dewender <github@JonnyJD.net>
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 55c3592..dff83ce 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
NAME = configshell
GIT_BRANCH = $$(git branch | grep \* | tr -d \*)
-VERSION = $$(basename $$(git describe --tags | tr - .))
+VERSION = $$(basename $$(git describe --tags | tr - . | sed 's/^v//'))
all:
@echo "Usage:"
@@ -52,7 +52,7 @@ build/release-stamp:
rm -r rpm
@echo "Generating rpm changelog..."
@( \
- version=$$(basename $$(git describe HEAD --tags | tr - .)); \
+ version=${VERSION}; \
author=$$(git show HEAD --format="format:%an <%ae>" -s); \
date=$$(git show HEAD --format="format:%ad" -s \
| awk '{print $$1,$$2,$$3,$$5}'); \
@@ -62,7 +62,7 @@ build/release-stamp:
) >> $$(ls build/${NAME}-${VERSION}/*.spec)
@echo "Generating debian changelog..."
@( \
- version=$$(basename $$(git describe HEAD --tags | tr - .)); \
+ version=${VERSION}; \
author=$$(git show HEAD --format="format:%an <%ae>" -s); \
date=$$(git show HEAD --format="format:%aD" -s); \
day=$$(git show HEAD --format='format:%ai' -s \