summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Vu-Brugier <cvubrugier@yahoo.fr>2013-10-12 18:37:22 +0200
committerChristophe Vu-Brugier <cvubrugier@yahoo.fr>2013-10-12 18:37:22 +0200
commit8aead336aca910e015faaa032da519518976ee72 (patch)
tree8786672273f1fa6d5c57d3524c85af835c823b92
parent062ec00a4dcb37a98a5cfe21b555b45909ebcb03 (diff)
downloadconfigshell-fb-8aead336aca910e015faaa032da519518976ee72.tar.gz
Use 2to3 in setup and mention that configshell-fb is Python 3 compatible
Signed-off-by: Christophe Vu-Brugier <cvubrugier@yahoo.fr>
-rw-r--r--README.md2
-rwxr-xr-xsetup.py3
2 files changed, 4 insertions, 1 deletions
diff --git a/README.md b/README.md
index 3f59325..3da1424 100644
--- a/README.md
+++ b/README.md
@@ -6,6 +6,8 @@ A Python library for building configuration shells
configshell-fb is a Python library that provides a framework
for building simple but nice CLI-based applications.
+This runs with Python 2 and 2to3 is run by setup.py to run on Python 3.
+
configshell-fb development
--------------------------
configshell-fb is licensed under the Apache 2.0 license. Contributions are welcome.
diff --git a/setup.py b/setup.py
index e17c7a0..4743008 100755
--- a/setup.py
+++ b/setup.py
@@ -16,7 +16,7 @@ License for the specific language governing permissions and limitations
under the License.
'''
-from distutils.core import setup
+from setuptools import setup
setup(
name = 'configshell-fb',
@@ -27,4 +27,5 @@ setup(
maintainer_email = 'agrover@redhat.com',
url = 'http://github.com/agrover/configshell-fb',
packages = ['configshell'],
+ use_2to3 = True,
)