summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4ef521d..4951959 100755
--- a/setup.py
+++ b/setup.py
@@ -7,7 +7,11 @@ except ImportError:
return ['sqlpython']
import sys
-install_requires = ['pyparsing>=1.5.6']
+if sys.version_info.major < 3:
+ install_requires = ['pyparsing == 1.5.7']
+else:
+ install_requires = ['pyparsing >= 2.0.0']
+
setup(
name="cmd2",
version="0.6.4",