summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xexample/example.py2
-rwxr-xr-xsetup.py7
2 files changed, 8 insertions, 1 deletions
diff --git a/example/example.py b/example/example.py
index 88cefd4..eabdd00 100755
--- a/example/example.py
+++ b/example/example.py
@@ -5,7 +5,7 @@ import unittest, optparse, sys
class CmdLineApp(Cmd):
multilineCommands = ['orate']
- Cmd.shortcuts.update({'&': 'speak'})
+ Cmd.shortcuts.update({'&': 'speak', 'h': 'hello'})
maxrepeats = 3
redirector = '->'
Cmd.settable.append('maxrepeats Max number of `--repeat`s allowed')
diff --git a/setup.py b/setup.py
index 03c42d6..fe525c7 100755
--- a/setup.py
+++ b/setup.py
@@ -61,6 +61,13 @@ See docs at http://packages.python.org/cmd2/
'Programming Language :: Python',
'License :: OSI Approved :: MIT License',
'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3.0',
+ 'Programming Language :: Python :: 3.1',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
+
],
)