summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorcatherine devlin <catherine.devlin@gmail.com>2010-09-19 15:42:47 -0400
committercatherine devlin <catherine.devlin@gmail.com>2010-09-19 15:42:47 -0400
commit614378219ecfaf2fad92b1c998c5d6969869fd22 (patch)
tree985607a87dc39abda969651945d7e2ca40b6e281 /setup.py
parent3cf5569d13c6feec7166a1cb36af047a100950e4 (diff)
downloadcmd2-hg-614378219ecfaf2fad92b1c998c5d6969869fd22.tar.gz
change version number to 0.6.2
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py13
1 files changed, 3 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 6258576..4599b9d 100755
--- a/setup.py
+++ b/setup.py
@@ -7,17 +7,11 @@ except ImportError:
return ['sqlpython']
import sys
-python3 = sys.version_info[0] > 2
-if python3:
- install_requires = [] # will rely on local pyparsing_py3 copy
- extra_modules = ["pyparsing_py3"]
-else:
- install_requires = ['pyparsing>=1.5.1']
- extra_modules = []
+install_requires = ['pyparsing>=1.5.5']
setup(
name="cmd2",
- version="0.6.1",
- py_modules=["cmd2"]+extra_modules,
+ version="0.6.2",
+ py_modules=["cmd2"],
use_2to3=True,
# metadata for upload to PyPI
@@ -28,7 +22,6 @@ setup(
keywords = 'command prompt console cmd',
url = 'http://packages.python.org/cmd2/',
install_requires = install_requires,
-
long_description = """Enhancements for standard library's cmd module.
Drop-in replacement adds several features for command-prompt tools: