summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcatherine devlin <catherine.devlin@gmail.com>2010-07-07 19:27:21 -0400
committercatherine devlin <catherine.devlin@gmail.com>2010-07-07 19:27:21 -0400
commit69dd928b7aa08747db0f467ce95e10a10869efcf (patch)
tree130da35e43a6f067f76c61030c55b9f63db984c8
parent6ed8221f054b8a3e05fe9e4f278bd57457eb7397 (diff)
parent7ed1e3bb5e54614c5c11db3a6032f50eec7c90f5 (diff)
downloadcmd2-hg-69dd928b7aa08747db0f467ce95e10a10869efcf.tar.gz
including deb packaging changes from Jens
-rw-r--r--debian/changelog7
-rw-r--r--debian/compat1
-rw-r--r--debian/control14
-rw-r--r--debian/pycompat1
-rwxr-xr-xdebian/rules7
-rwxr-xr-xsetup.py5
6 files changed, 33 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..7a6b8ad
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,7 @@
+python-cmd2 (0.6.1) unstable; urgency=low
+
+ * Debian package
+ * Source: http://hg.assembla.com/python-cmd2
+
+ -- Jens Braeuer <jens.braeuer@gmx.net> Tue, 18 May 2010 20:35:13 +0200
+ \ No newline at end of file
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..516665b
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,14 @@
+Source: python-cmd2
+Section: contrib/misc
+Priority: standard
+Maintainer: Jens Braeuer <jens.braeuer@gmx.net>
+Build-Depends: debhelper, cdbs, debhelper (>= 5.0.38), python-all-dev (>= 2.3.5-11),
+XS-Python-Version: >= 2.5
+
+Package: python-cmd2
+Section: contrib/misc
+Priority: standard
+Architecture: all
+Depends: ${python:Depends}, python-pyparsing (>= 1.5.1), xclip
+Description: Cmd2
+XB-Python-Version: ${python:Versions}
diff --git a/debian/pycompat b/debian/pycompat
new file mode 100644
index 0000000..0cfbf08
--- /dev/null
+++ b/debian/pycompat
@@ -0,0 +1 @@
+2
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..25b5ccd
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,7 @@
+#!/usr/bin/make -f
+
+DEB_PYTHON_SYSTEM := pysupport
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/python-distutils.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
diff --git a/setup.py b/setup.py
index 70c4d45..3cda4ba 100755
--- a/setup.py
+++ b/setup.py
@@ -10,13 +10,14 @@ import sys
python3 = sys.version_info[0] > 2
if python3:
install_requires = [] # will rely on local pyparsing_py3 copy
+ extra_modules = "pyparsing_py3"
else:
install_requires = ['pyparsing>=1.5.1']
-
+ extra_modules = []
setup(
name="cmd2",
version="0.6.1",
- py_modules=["cmd2","pyparsing_py3"],
+ py_modules=["cmd2"]+extra_modules,
use_2to3=True,
# metadata for upload to PyPI