summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2015-07-09 17:25:39 +0200
committerArmin Rigo <arigo@tunes.org>2015-07-09 17:25:39 +0200
commit0a74254d751ff2b67a754aaa334c224462259980 (patch)
tree31e2ac59b96716dcacaa77ce52a719cd39e50847
parent91b0007436f249c64ac11c13d9ec6ae231e01584 (diff)
downloadcffi-0a74254d751ff2b67a754aaa334c224462259980.tar.gz
Tweaks
-rw-r--r--doc/source/cdef.rst2
-rw-r--r--doc/source/installation.rst8
-rw-r--r--doc/source/overview.rst4
3 files changed, 7 insertions, 7 deletions
diff --git a/doc/source/cdef.rst b/doc/source/cdef.rst
index a0cd2bb..7d55baa 100644
--- a/doc/source/cdef.rst
+++ b/doc/source/cdef.rst
@@ -231,6 +231,8 @@ strings as arguments instead of not byte strings. (Before cffi version 0.9,
inconsistently, not defined by default.)
+.. _loading-libraries:
+
ffi.dlopen(): loading libraries in ABI mode
-------------------------------------------
diff --git a/doc/source/installation.rst b/doc/source/installation.rst
index 04a0adf..6456646 100644
--- a/doc/source/installation.rst
+++ b/doc/source/installation.rst
@@ -53,21 +53,19 @@ Download and Installation:
* http://pypi.python.org/packages/source/c/cffi/cffi-1.2.0.tar.gz
- - Or grab the most current version by following the instructions below.
-
- MD5: ...
- SHA: ...
-* Or get it from the `Bitbucket page`_:
+* Or grab the most current version from the `Bitbucket page`_:
``hg clone https://bitbucket.org/cffi/cffi``
* ``python setup.py install`` or ``python setup_base.py install``
(should work out of the box on Linux or Windows; see below for
`MacOS X`_ or `Windows 64`_.)
-* running the tests: ``py.test c/ _cffi1/ testing/`` (if you didn't
- install cffi yet, you may need ``python setup_base.py build_ext -f
+* running the tests: ``py.test c/ testing/`` (if you didn't
+ install cffi yet, you need first ``python setup_base.py build_ext -f
-i``)
.. _`Bitbucket page`: https://bitbucket.org/cffi/cffi
diff --git a/doc/source/overview.rst b/doc/source/overview.rst
index 1e76a48..fa93864 100644
--- a/doc/source/overview.rst
+++ b/doc/source/overview.rst
@@ -33,8 +33,8 @@ Simple example (ABI level, in-line)
... """)
>>> C = ffi.dlopen(None) # loads the entire C namespace
>>> arg = ffi.new("char[]", "world") # equivalent to C code: char arg[] = "world";
- >>> C.printf("hi there, %s!\n", arg) # call printf
- hi there, world!
+ >>> C.printf("hi there, %s.\n", arg) # call printf
+ hi there, world.
17 # this is the return value
>>>