summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2016-09-20 15:12:33 +0200
committerArmin Rigo <arigo@tunes.org>2016-09-20 15:12:33 +0200
commitc976ed5c027ee93386518efdee2bbc26566903c9 (patch)
treec0fc59f7e642bcd6a5043b33950b32da29a8a826
parentd067b48aa4660487e050e396ff957d916d5183c4 (diff)
downloadcffi-c976ed5c027ee93386518efdee2bbc26566903c9.tar.gz
update to 1.8.4 and add whatsnew
-rw-r--r--c/_cffi_backend.c2
-rw-r--r--c/test_c.py2
-rw-r--r--cffi/__init__.py4
-rw-r--r--cffi/_embedding.h2
-rw-r--r--doc/source/conf.py2
-rw-r--r--doc/source/installation.rst8
-rw-r--r--doc/source/whatsnew.rst8
-rw-r--r--setup.py2
8 files changed, 19 insertions, 11 deletions
diff --git a/c/_cffi_backend.c b/c/_cffi_backend.c
index f32547e..6da7912 100644
--- a/c/_cffi_backend.c
+++ b/c/_cffi_backend.c
@@ -2,7 +2,7 @@
#include <Python.h>
#include "structmember.h"
-#define CFFI_VERSION "1.8.3"
+#define CFFI_VERSION "1.8.4"
#ifdef MS_WIN32
#include <windows.h>
diff --git a/c/test_c.py b/c/test_c.py
index 0b27bd7..3d5f23b 100644
--- a/c/test_c.py
+++ b/c/test_c.py
@@ -12,7 +12,7 @@ from _cffi_backend import _testfunc, _get_types, _get_common_types, __version__
# ____________________________________________________________
import sys
-assert __version__ == "1.8.3", ("This test_c.py file is for testing a version"
+assert __version__ == "1.8.4", ("This test_c.py file is for testing a version"
" of cffi that differs from the one that we"
" get from 'import _cffi_backend'")
if sys.version_info < (3,):
diff --git a/cffi/__init__.py b/cffi/__init__.py
index b09647e..532454d 100644
--- a/cffi/__init__.py
+++ b/cffi/__init__.py
@@ -4,8 +4,8 @@ __all__ = ['FFI', 'VerificationError', 'VerificationMissing', 'CDefError',
from .api import FFI, CDefError, FFIError
from .ffiplatform import VerificationError, VerificationMissing
-__version__ = "1.8.3"
-__version_info__ = (1, 8, 3)
+__version__ = "1.8.4"
+__version_info__ = (1, 8, 4)
# The verifier module file names are based on the CRC32 of a string that
# contains the following version number. It may be older than __version__
diff --git a/cffi/_embedding.h b/cffi/_embedding.h
index 8d23b50..0b2fae1 100644
--- a/cffi/_embedding.h
+++ b/cffi/_embedding.h
@@ -233,7 +233,7 @@ static int _cffi_initialize_python(void)
f = PySys_GetObject((char *)"stderr");
if (f != NULL && f != Py_None) {
PyFile_WriteString("\nFrom: " _CFFI_MODULE_NAME
- "\ncompiled with cffi version: 1.8.3"
+ "\ncompiled with cffi version: 1.8.4"
"\n_cffi_backend module: ", f);
modules = PyImport_GetModuleDict();
mod = PyDict_GetItemString(modules, "_cffi_backend");
diff --git a/doc/source/conf.py b/doc/source/conf.py
index 3e73f90..a908f51 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -47,7 +47,7 @@ copyright = u'2012-2015, Armin Rigo, Maciej Fijalkowski'
# The short X.Y version.
version = '1.8'
# The full version, including alpha/beta/rc tags.
-release = '1.8.3'
+release = '1.8.4'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/doc/source/installation.rst b/doc/source/installation.rst
index 8682265..568341f 100644
--- a/doc/source/installation.rst
+++ b/doc/source/installation.rst
@@ -51,13 +51,13 @@ Requirements:
Download and Installation:
-* http://pypi.python.org/packages/source/c/cffi/cffi-1.8.3.tar.gz
+* http://pypi.python.org/packages/source/c/cffi/cffi-1.8.4.tar.gz
- - MD5: c8e877fe0426a99d0cf5872cf2f95b27
+ - MD5: ...
- - SHA: 2a5be10205bf3f6b21070a71ee2546d838868172
+ - SHA: ...
- - SHA256: c321bd46faa7847261b89c0469569530cad5a41976bb6dba8202c0159f476568
+ - SHA256: ...
* Or grab the most current version from the `Bitbucket page`_:
``hg clone https://bitbucket.org/cffi/cffi``
diff --git a/doc/source/whatsnew.rst b/doc/source/whatsnew.rst
index cbcd4fd..ec8f214 100644
--- a/doc/source/whatsnew.rst
+++ b/doc/source/whatsnew.rst
@@ -3,6 +3,14 @@ What's New
======================
+v1.8.4
+======
+
+* Add support in ``cdef()/set_source()`` for unspecified-length arrays
+ in typedefs: ``typedef int foo_t[...];``. It was already supported
+ for global variables or structure fields.
+
+
v1.8.3
======
diff --git a/setup.py b/setup.py
index a0acce5..d30f057 100644
--- a/setup.py
+++ b/setup.py
@@ -144,7 +144,7 @@ Contact
`Mailing list <https://groups.google.com/forum/#!forum/python-cffi>`_
""",
- version='1.8.3',
+ version='1.8.4',
packages=['cffi'] if cpython else [],
package_data={'cffi': ['_cffi_include.h', 'parse_c_type.h',
'_embedding.h']}