summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo <hugovk@users.noreply.github.com>2019-11-02 23:41:32 +0200
committerHugo <hugovk@users.noreply.github.com>2019-11-02 23:41:32 +0200
commit1945b59e0fe49f2b8663b0d02d9f0c98cd7dd453 (patch)
tree97a19154eac0ad71c9237d0ba4bb0030607f67ff
parent6f86085e71661d874c6c56f49c76044c9b7f29c0 (diff)
downloadblinker-1945b59e0fe49f2b8663b0d02d9f0c98cd7dd453.tar.gz
Add support for Python 3.8
-rw-r--r--.travis.yml4
-rw-r--r--setup.py3
-rw-r--r--tox.ini2
3 files changed, 7 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index cb889b5..995721e 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -22,6 +22,10 @@ matrix:
os: linux
dist: xenial
env: TOXENV=py37
+ - python: 3.8
+ os: linux
+ dist: xenial
+ env: TOXENV=py38
# command to install dependencies
install:
diff --git a/setup.py b/setup.py
index 2f81494..ccfd67a 100644
--- a/setup.py
+++ b/setup.py
@@ -16,7 +16,7 @@ setup(name="blinker",
keywords='signal emit events broadcast',
long_description=readme,
license='MIT License',
- url='http://pythonhosted.org/blinker/',
+ url='https://pythonhosted.org/blinker/',
python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*',
classifiers=[
'Development Status :: 5 - Production/Stable',
@@ -30,6 +30,7 @@ setup(name="blinker",
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Topic :: Software Development :: Libraries',
'Topic :: Utilities',
],
diff --git a/tox.ini b/tox.ini
index ddcfd38..a6e07ae 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27,py35,py36,py37,jython
+envlist = py27,py35,py36,py37,py38,jython
[testenv]
deps=nose