summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo <hugovk@users.noreply.github.com>2019-04-22 11:47:35 +0300
committerGitHub <noreply@github.com>2019-04-22 11:47:35 +0300
commit17653564e53669899275d23f60b4c7b162218293 (patch)
tree910e865bdccdc6f79546ba6054a603150c482b96
parentf92e54348bdc9fe3e015e73b200f61043bc11152 (diff)
parent398ef40a52749dfa005609f6b1f5b180fb4b3fbe (diff)
downloadblinker-17653564e53669899275d23f60b4c7b162218293.tar.gz
Merge branch 'master' into rm-eol
-rw-r--r--.travis.yml28
-rw-r--r--CHANGES1
-rw-r--r--blinker/base.py8
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
5 files changed, 30 insertions, 10 deletions
diff --git a/.travis.yml b/.travis.yml
index 91481c6..cb889b5 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,9 +1,27 @@
language: python
-python:
- - "2.7"
- - "3.5"
- - "3.6"
- - "pypy"
+
+matrix:
+ include:
+ - python: 2.7
+ os: linux
+ dist: trusty
+ env: TOXENV=py27
+ - python: pypy
+ os: linux
+ dist: trusty
+ env: TOXENV=pypy
+ - python: 3.5
+ os: linux
+ dist: trusty
+ env: TOXENV=py35
+ - python: 3.6
+ os: linux
+ dist: trusty
+ env: TOXENV=py36
+ - python: 3.7
+ os: linux
+ dist: xenial
+ env: TOXENV=py37
# command to install dependencies
install:
diff --git a/CHANGES b/CHANGES
index 6180b17..9777302 100644
--- a/CHANGES
+++ b/CHANGES
@@ -7,6 +7,7 @@ Version 1.5dev
Not yet released.
+- Verified Python 3.7 support (no changes needed).
- Verified Python 3.6 support (no changes needed).
- Verified Python 3.5 support (no changes needed).
diff --git a/blinker/base.py b/blinker/base.py
index acf595b..52b9a6b 100644
--- a/blinker/base.py
+++ b/blinker/base.py
@@ -354,9 +354,9 @@ class Signal(object):
self._by_receiver[receiver_id].discard(sender_id)
def _cleanup_bookkeeping(self):
- """Prune unused sender/receiver bookeeping. Not threadsafe.
+ """Prune unused sender/receiver bookkeeping. Not threadsafe.
- Connecting & disconnecting leave behind a small amount of bookeeping
+ Connecting & disconnecting leave behind a small amount of bookkeeping
for the receiver and sender values. Typical workloads using Blinker,
for example in most web apps, Flask, CLI scripts, etc., are not
adversely affected by this bookkeeping.
@@ -364,10 +364,10 @@ class Signal(object):
With a long-running Python process performing dynamic signal routing
with high volume- e.g. connecting to function closures, "senders" are
all unique object instances, and doing all of this over and over- you
- may see memory usage will grow due to extraneous bookeeping. (An empty
+ may see memory usage will grow due to extraneous bookkeeping. (An empty
set() for each stale sender/receiver pair.)
- This method will prune that bookeeping away, with the caveat that such
+ This method will prune that bookkeeping away, with the caveat that such
pruning is not threadsafe. The risk is that cleanup of a fully
disconnected receiver/sender pair occurs while another thread is
connecting that same pair. If you are in the highly dynamic, unique
diff --git a/setup.py b/setup.py
index 0d62b49..2f81494 100644
--- a/setup.py
+++ b/setup.py
@@ -29,6 +29,7 @@ setup(name="blinker",
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Topic :: Software Development :: Libraries',
'Topic :: Utilities',
],
diff --git a/tox.ini b/tox.ini
index 8f5146f..ddcfd38 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27,py35,py36,jython
+envlist = py27,py35,py36,py37,jython
[testenv]
deps=nose