summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Finkelstein <jeffrey.finkelstein@gmail.com>2016-06-23 16:25:51 -0400
committerJeffrey Finkelstein <jeffrey.finkelstein@gmail.com>2016-06-23 16:25:51 -0400
commitb7d847d71e63254a8870ba25c12867c7c9b242d2 (patch)
tree80cab5b3988008db2cdcbea28cc17ddb04dda411
parent25457e39eb3bfa23ed9fde401802aec8024f5850 (diff)
downloadblinker-b7d847d71e63254a8870ba25c12867c7c9b242d2.tar.gz
Adds Python 3.5 to test suite.
No changes to the code are required to support Python 3.5.
-rw-r--r--.travis.yml1
-rw-r--r--CHANGES3
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
4 files changed, 6 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 952e3d6..3c30512 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,6 +5,7 @@ python:
- "3.2"
- "3.3"
- "3.4"
+ - "3.5"
# command to install dependencies
install:
diff --git a/CHANGES b/CHANGES
index 9346a3c..e36743f 100644
--- a/CHANGES
+++ b/CHANGES
@@ -5,6 +5,9 @@ Blinker Changelog
Version 1.5dev
--------------
+Not yet released.
+
+- Verified Python 3.5 support (no changes needed).
Version 1.4
-----------
diff --git a/setup.py b/setup.py
index 8655223..7eb87ea 100644
--- a/setup.py
+++ b/setup.py
@@ -34,6 +34,7 @@ setup(name="blinker",
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
'Topic :: Software Development :: Libraries',
'Topic :: Utilities',
],
diff --git a/tox.ini b/tox.ini
index 0f9a8c5..5046326 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py25,py26,py27,py30,py31,py32,py33,py34,jython
+envlist = py25,py26,py27,py30,py31,py32,py33,py34,py35,jython
[testenv]
deps=nose