summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjason kirtland <jek@discorporate.us>2010-02-14 10:14:07 -0800
committerjason kirtland <jek@discorporate.us>2010-02-14 10:14:07 -0800
commite17d6b6242739e99be0bcdec1c13b063444ce52e (patch)
tree19ddd040b2df6339d456eb6c099d0f73a2a2e0c8
parentd4c3ef3f5f0a67db9c3ea564260473489e7454dd (diff)
downloadblinker-e17d6b6242739e99be0bcdec1c13b063444ce52e.tar.gz
Tweaks for releasability.
-rw-r--r--.hgignore3
-rw-r--r--AUTHORS8
-rw-r--r--LICENSE20
-rw-r--r--MANIFEST.in5
-rw-r--r--README28
-rw-r--r--blinker/__init__.py3
-rw-r--r--setup.py19
7 files changed, 75 insertions, 11 deletions
diff --git a/.hgignore b/.hgignore
index 9b7dcc2..ffcb4d6 100644
--- a/.hgignore
+++ b/.hgignore
@@ -4,3 +4,6 @@ syntax: glob
nosetests3
bench
*.py?
+build
+dist
+MANIFEST
diff --git a/AUTHORS b/AUTHORS
new file mode 100644
index 0000000..ee0dd62
--- /dev/null
+++ b/AUTHORS
@@ -0,0 +1,8 @@
+Blinker was originally written by Jason Kirtland.
+
+Contributors are:
+
+- Jason Kirtland <jek@discorporate.us>
+
+Blinker includes code from Louie, by Patrick K. O'Brien, Mike
+C. Fletcher, and Matthew R. Scott.
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 0000000..88f6e84
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,20 @@
+Copyright (c) The Blinker authors and contributors <see AUTHORS file>
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be included
+in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
+LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
+WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/MANIFEST.in b/MANIFEST.in
new file mode 100644
index 0000000..01583e8
--- /dev/null
+++ b/MANIFEST.in
@@ -0,0 +1,5 @@
+include LICENSE
+include README
+include AUTHORS
+recursive-include tests *py
+
diff --git a/README b/README
new file mode 100644
index 0000000..2725785
--- /dev/null
+++ b/README
@@ -0,0 +1,28 @@
+Blinker
+=======
+
+Blinker provides a fast dispatching system that allows any number of
+interested parties to subscribe to events, or "signals".
+
+Signal receivers can subscribe to specific senders or receive signals
+sent by any sender.
+
+ >>> from blinker import Signal
+ >>> signal = Signal('round_started')
+ >>> def each(round):
+ ... print "Round %s!" % round
+ ...
+ >>> signal.connect(each)
+ >>> def round_two(round):
+ ... print "This is round two."
+ ...
+ >>> signal.connect(round_two, sender=2)
+
+ >>> for round in range(1, 4):
+ ... signal.send(round)
+ ...
+ Round 1!
+ Round 2!
+ This is round two.
+ Round 3!
+
diff --git a/blinker/__init__.py b/blinker/__init__.py
index 01ab251..2019d54 100644
--- a/blinker/__init__.py
+++ b/blinker/__init__.py
@@ -15,3 +15,6 @@ __all__ = [
'receiver_connected',
'signal',
]
+
+
+__version__ = '0.8'
diff --git a/setup.py b/setup.py
index 103919c..003d309 100644
--- a/setup.py
+++ b/setup.py
@@ -1,22 +1,19 @@
-"""
-blinker
-~~~~~~~
-
-
-"""
-from distutils.tools import setup
+from distutils.core import setup
+readme = open('README').read()
+import blinker
+version = blinker.__version__
setup(name="blinker",
- version="0.8",
+ version=version,
packages=['blinker'],
author='Jason Kirtland',
author_email='jek@discorporate.us',
- description='fast and simple object-to-object and broadcast signalling',
+ description='Fast, simple object-to-object and broadcast signaling',
keywords='signal emit events broadcast',
- long_description=__doc__,
+ long_description=readme,
license='MIT License',
- url='http://discorporate.us/jek/projects/blinker/',
+ url='http://bitbucket.org/jek/blinker/',
classifiers=[
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',