summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSylvain Th?nault <sylvain.thenault@logilab.fr>2013-10-03 16:31:51 +0200
committerSylvain Th?nault <sylvain.thenault@logilab.fr>2013-10-03 16:31:51 +0200
commit477bf68079dbcd2ba7e70aedd7d4f0dce31aaf64 (patch)
treed9a3bb41f3cc2560fcd33337fabe7a67929bff80
parent6613126d363b10e3561a6b0bbfa30781a2372936 (diff)
downloadastroid-477bf68079dbcd2ba7e70aedd7d4f0dce31aaf64.tar.gz
backport fix done by Tobias Rzepka on pylint for python3 install on win32 platforms
-rw-r--r--ChangeLog3
-rw-r--r--setup.py10
2 files changed, 11 insertions, 2 deletions
diff --git a/ChangeLog b/ChangeLog
index 034dcbf..6c858bd 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,9 @@
Change log for the astroid package (used to be astng)
=====================================================
+--
+ * fix bug with namedtuple inference (issue #3)
+
2013-07-29 -- 1.0.0
* Fix some omissions in py2stdlib's version of hashlib and
add a small test for it.
diff --git a/setup.py b/setup.py
index b5c8a2c..df2a1d9 100644
--- a/setup.py
+++ b/setup.py
@@ -132,7 +132,13 @@ class MyBuildPy(build_py):
else:
base = modname
basedir = os.path.join(self.build_lib, base)
- for directory in include_dirs:
+ if sys.platform == 'win32':
+ two_to_three = [sys.executable]
+ exe_path = os.path.dirname(sys.executable)
+ two_to_three.append(os.path.join(exe_path, 'Tools\\Scripts\\2to3.py'))
+ else:
+ two_to_three = ['2to3']
+ for directory in include_idirs:
dest = join(basedir, directory)
shutil.rmtree(dest, ignore_errors=True)
shutil.copytree(directory, dest)
@@ -140,7 +146,7 @@ class MyBuildPy(build_py):
# process manually python file in include_dirs (test data)
from subprocess import check_call
print('running 2to3 on', dest) # parens are NOT optional here for py3k compat
- check_call(['2to3', '-wn', dest])
+ check_call(two_to_three + ['-wn', dest])
def install(**kwargs):
"""setup entry point"""