summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini17
1 files changed, 4 insertions, 13 deletions
diff --git a/tox.ini b/tox.ini
index 956a193..26a882e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -9,19 +9,10 @@ commands = coverage run -m pytest {posargs}
extras = test
[testenv:lint]
-deps =
- isort
- autopep8
-commands =
- autopep8 -r -i src tests
- isort src tests
-skip_install = true
-
-[testenv:flake8]
-basepython = python3.7
-depends = lint
-deps = pyproject-flake8
-commands = pflake8 src tests
+depends =
+basepython = python3
+deps = pre-commit
+commands = pre-commit run --all-files --show-diff-on-failure
skip_install = true
[testenv:mypy]